[Window Management][RTL]Icons in the status bar will overlap when the notifications tab is pulled down

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: cnelson, Assigned: apastor)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe], URL)

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Posted file log.txt
When the user pulls down the notifications tab, they will notice that the icons in the status bar will overlap.


Repro Steps:
1) Update a Flame to 20141223010202
2) Set Flame device to Arabic language.
3) Pull down the notifications tab. 
4) Noitice the some of the icons are overlapping.


Actual:
Icons in the status bar will overlap when the notifications tab is pulled down


Expected:
Icons don't overlap in the status bar when the notifications tab is pulled down

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141223010202
Gaia: c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko: 0532f2509f3f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 100%
See attached: logcat, video clip http://youtu.be/P_rO5S2KELc
Flags: needinfo?(dharris)
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Blocks: status-bar-rtl
No longer blocks: notifications-rtl
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(dharris)
RTL triage: P3 -- this bug is not prioritized for inclusion in the 2.2 release.
Priority: -- → P3
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
blocking-b2g: --- → 2.2?
Whiteboard: [systemsfe]
(Assignee)

Updated

4 years ago
Attachment #8555768 - Flags: review?(gmarty)
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8555768 [details] [review]
[PullReq] albertopq:1115172-date-rtl to mozilla-b2g:master

Looks good to me!
Attachment #8555768 - Flags: review?(gmarty) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 7

4 years ago
Hi Reporter,
    I have verified this issue on Flame master, but I can't make sure whether the solution is verified failed or not in this issue, can youe help to confirm it? Thanks.
 
Reproduce rate:5/5.
Attachment:Verify_RTL_Notification.mp4,logcat_15:27.txt
Time:15:27

Precondition:
 1.Insert SIM card, connetc a WIFI.
 2. Change system language to Arabic.
STRs:
 1. Keep device in supend mode.
 2. Press power key, unlock device.
 **The WIFI's icon is overlapping with icon of SIM card.
 3. Pull down notification tab.
 **The icons still overlap each other.

Master build:

Gaia-Rev        ab69ae06a7f2b54e60ab63b1b44c8d19d5d20d94
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/c2359a6a6958
Build-ID        20150201010217
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150201.044915
FW-Date         Sun Feb  1 04:49:25 EST 2015
Bootloader      L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
Flags: needinfo?(cnelson)

Comment 8

4 years ago

Comment 9

4 years ago
Posted file logcat_1527.txt
This issue is Verified Fixed in the latest Flame 3.0 build.
Icons in the status bar are not overlapping when the notification tray is pulled down.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150205010209
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: 34a66aaaca81
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Adding verifyme keyword to check 2.2 after uplift.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+] → [QAnalyst-Triage?][rtl-impact], [MGSEI-Triage+]
Flags: needinfo?(cnelson) → needinfo?(pbylenga)
Keywords: verifyme
Marty can you check this on 2.2 when it lands?
QA Whiteboard: [QAnalyst-Triage?][rtl-impact], [MGSEI-Triage+] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(mshuman)
Please request Gaia v2.2 approval on this when you get a chance (since I noticed that Alberto is on PTO).
Flags: needinfo?(gmarty)
Target Milestone: --- → 2.2 S5 (6feb)
Comment on attachment 8555768 [details] [review]
[PullReq] albertopq:1115172-date-rtl to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL on the status bar/utility tray
[User impact] if declined: The date overlaps the status bar when the utility tray is opened. Very bad UI.
[Testing completed]: Manual testing required
[Risk to taking this patch] (and alternatives if risky): low risk as it's a CSS change ony
[String changes made]: None
Flags: needinfo?(gmarty)
Attachment #8555768 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8555768 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is Verified Fixed in the latest Flame 2.2 build.
Icons in the status bar are not overlapping when the notification tray is pulled down.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150213002503
Gaia: ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gecko: d04b78eeb536
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+] → [QAnalyst-Triage?][rtl-impact], [MGSEI-Triage+]
Flags: needinfo?(mshuman) → needinfo?(pbylenga)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][rtl-impact], [MGSEI-Triage+] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
Flags: needinfo?(pbylenga)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15659/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.