[Browser][RTL] URLs overlap the refresh/stop icon on the right side of text box

VERIFIED DUPLICATE of bug 1033917

Status

Firefox OS
Gaia::Browser
VERIFIED DUPLICATE of bug 1033917
3 years ago
3 years ago

People

(Reporter: RobertM, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8540974 [details]
2014-12-23-14-39-04.png

Description:
When visiting a website with a large URL, the text overlaps the refresh/stop icon on the right side of the text box.


Repro Steps:
1) Update a Flame to 20141223010202
2) Toggle language to a RTL language(like Arabic)
3) Go to website with a large url (ex: Go to youtube and select a video)


Actual:
The URL text overlaps the icon on the right of the text box


Expected:
The icon on the right side of text box is not overlapped


Environmental Variables:
Device: Flame 2.2(319mb)(KitKat)(Full Flash)
Build ID: 20141223010202
Gaia: c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko: 0532f2509f3f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Repro frequency: 100%
See attached: screenshot
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(dharris)
The bug occurs no matter the length of the URL. Updating the title to this bug.
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(dharris)
Summary: [Browser][RTL] Long URLs overlap the refresh/stop icon on the right side of text box → [Browser][RTL] URLs overlap the refresh/stop icon on the right side of text box
Fixed in 1033917.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1033917
Flags: in-moztrap+
Created attachment 8641585 [details]
N5_v2.2.png

Since Bug 1033917 has been verified as pass, this issue is verified as pass on latest Flame KK v2.2/v2.5 and N5 v2.2/v2.5 build. The refresh/stop icon is shown at left side of the text and dose not overlap each other.
Reproducing rate:0/10
See attachment:N5_v2.2.png

Device: Flame KK v2.2 (Pass)
Build ID               20150730032503
Gaia Revision          8f3749f875c5ed155ccbd630aa2ee4e8bc2a9400
Gaia Date              2015-07-29 14:28:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e2a82fd90bc5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150730.072830
Firmware Date          Thu Jul 30 07:28:41 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.5 (Pass)
Build ID               20150730150205
Gaia Revision          7e7e92fbeea90cad8bf6f494b1a73712f79178e8
Gaia Date              2015-07-30 17:03:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/23e525e2ba35
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150730.183847
Firmware Date          Thu Jul 30 18:38:56 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: N5 v2.2 build (Pass)
Build ID               20150730032503
Gaia Revision          8f3749f875c5ed155ccbd630aa2ee4e8bc2a9400
Gaia Date              2015-07-29 14:28:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e2a82fd90bc5
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150730.070748
Firmware Date          Thu Jul 30 07:08:07 EDT 2015
Bootloader             HHZ12f

Device: N5 v2.5 build (Pass)
Build ID               20150730150205
Gaia Revision          7e7e92fbeea90cad8bf6f494b1a73712f79178e8
Gaia Date              2015-07-30 17:03:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/23e525e2ba35
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150730.183055
Firmware Date          Thu Jul 30 18:31:09 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
status-b2g-v2.2: affected → verified
status-b2g-master: --- → verified
You need to log in before you can comment on or make changes to this bug.