Closed Bug 1115563 Opened 10 years ago Closed 9 years ago

Multiple data calls are placed when enabling data connection

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: gerard-majax, Unassigned)

References

Details

(Keywords: regression)

I have noticed this recently, and only on recent builds (geecko/gaia tree from dec 24th).

So far, I cannot document clear STR nor give more details on Flame, since I'm reproducing this on my dogfooding device (Nexus S), but it looks like this happens right after I have sent a couple of MMS.

STR (not sure) :
 0. Send a couple of MMS
 1. Press power, wait a couple of minutes
 2. Press power, enable data

Expected:
 Only data APN gets connected ("free" in my case)

Actual:
 Data APN and MMS APN gets connected both ("free", "mmsfree")

Confirmed by:
 - looking at adb logcat -v threadtime -b radio: one call for free, one call for mmsfree
 - two network interfaces getting up: rmnet0 and rmnet1

Maybe it is related to  bug 1114955 ?
It doesn't looks like relating to bug 1114955.
Bug 1114955 is about the apn configuration doesn't be saved in database correctly in first boot up. And data connection is unable to be established until user browse `Setting->APN->data`.
This bug looks like a different scenario.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.