Closed Bug 111561 Opened 20 years ago Closed 14 years ago

page displayed incorrectly

Categories

(Core Graveyard :: GFX, defect, P2)

x86
Windows ME
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME
Future

People

(Reporter: mik, Assigned: kmcclusk)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

Certain sections in the page at http://www.codeproject.com/jscript/javatojs.asp,
are rendered incorrectly if scrolled up/down with the scrollbar. Looks like
there are some problems with the tables.



Reproducible: Always
Steps to Reproduce:
1. goto http://www.codeproject.com/jscript/javatojs.asp
2. wait for the full loading
3. scroll the page up and down (or try to select the page text with the mouse)

Actual Results:  Garbage is displayed in the page. Not everywhere, but in
certain sections of the page. Search for "When Dynamic HTML finally started
taking shape
" in the page. Could be a table..

Expected Results:  Correct visualization of the page contents.
using moz 0.9.6 on win2k, wfm, page has some badly nested <p> inside lists 
and some wrong nested <a>s in the lower table. over the whole page more or less
severe mistakes.
I see this on current linux (2001-11-23-08).  There's a space that stays blank
unless you highlight it, then it gets some text....

compositor
Assignee: asa → kmcclusk
Status: UNCONFIRMED → NEW
Component: Browser-General → Compositor
Ever confirmed: true
QA Contact: doronr → petersen
Oh, to reproduce, search for that text then scroll down with down arrow.  You'll
see blank space.  Hitting pgup/pgdown will make the space paint correctly
Target Milestone: --- → mozilla1.1
Bulk moving Mozilla1.1 bugs to future-P2. I will pull from this list when
scheduling post Mozilla1.0 work.
Priority: -- → P2
Target Milestone: mozilla1.1 → Future
Codeproject seems to have this an awful lot.
For example:
http://www.codeproject.com/cpp/MatrixContainer.asp
has garbage for almost half the page and corrupts a banner image as well.
*** Bug 160483 has been marked as a duplicate of this bug. ***
this is also reported in bug 120370 and bug 152645
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021504 
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.