[B2G][Stingray] unable to focus when notification shows up from api-demos-tv app

RESOLVED WONTFIX

Status

Firefox OS
General
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: seanlin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ft:conndevices])

The focus cannot be set to the notification box when it shows up on api-demos-tv app.

Environment: b2g desktop (on Ubuntu)

STR:
1. Open api-demos-tv app.
2. Click one of the buttons to send a notification.
3. When the notification shows up, the focus cannot be changed to it.

After a brief investigation, the root cause looks the same as that in comment 9 of bug 1113592. A possible fix could be to blur the original focused window first and then change focus to the element in the notification box.

Please see bug 1111417 for more details about api-demos-tv app.

To run the TV build in b2g desktop:
/…/b2g-bin -profile /…/gaia/profile -screen 1920x1080
No longer blocks: 1115288
Blocks: 1105935
Depends on: 1111417
No longer depends on: 1113592, 1115455

Updated

3 years ago
Blocks: 1146810

Comment 1

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.