Closed Bug 1115740 Opened 8 years ago Closed 1 year ago

Don't bailout in an int32 unbox for double type that fits in int32

Categories

(Core :: JavaScript Engine: JIT, defect, P5)

x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1686702

People

(Reporter: h4writer, Unassigned)

References

(Blocks 1 open bug)

Details

int32 -> MToDouble -> MBox -> MUnbox<int32> bails currently, which is unfortunate. We should support this.
Blocks: 1114981
Improves mandreel from 2738 to 14118 again after applying bug 1114981. (before patch it is 28529, so not fully fixed yet)
Blocks: jsperf
Priority: -- → P5

Is this bug still relevant and free to work on? I thought about adding a code path to CodeGenerator::visitUnbox in the individual js/src/jit/X/CodeGenerator-X.cpp files. Alternatively, masm.fallibleUnboxInt32 could be upgraded with more logic.
One minor note: js/src/jit/mips32/CodeGenerator-mips32.cpp doesn't seem to implement infallible unboxing of int32?

Iain, is this issue fixed through the changes from bug 1686702?

Flags: needinfo?(iireland)

Yeah, I think the changes to MUnbox::foldsTo in bug 1686702 cover this.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(iireland)
Resolution: --- → DUPLICATE
Duplicate of bug: 1686702
You need to log in before you can comment on or make changes to this bug.