printing text messages uses Times-Roman font that screws up alignment

VERIFIED DUPLICATE of bug 37685

Status

MailNews Core
Printing
VERIFIED DUPLICATE of bug 37685
17 years ago
10 years ago

People

(Reporter: James Henstridge, Assigned: dcone (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112013

When printing a text mail message with the gtk build of mozilla mail, The
message apears to be aligned for the font metrics of the Courier font, but uses
the Times-Roman font.

If there were any URLs in the message, the underlines extend too far, because
the text is shorter when rendered with Times.

Reproducible: Always
Steps to Reproduce:
1.Select a text email message in messenger
2.click print button
3.print to printer or file (doesn't make a difference

Actual Results:  message prints in Times using font metrics of Courier

Expected Results:  message prints in Courier using the font metrics of Courier

When I press the print button, an additional window pops up displaying how the
printed page would look (I assume this is an HTML rendering of the message, due
to using the same printing code as for the browser).  In this window, the
message is displayed in a fixed font.

If I edit the generated postscript (from print to file) to use Courier, the
underlines for urls match up with the text, and things line up correctly.
(Reporter)

Comment 1

17 years ago
Created attachment 58953 [details]
Sample postscript output of printing

Here is an example printout of a message with screwed up metrics.

Running "sed s/Times-Roman/Courier/" on the file yields the correctly rendered
message.

Comment 2

17 years ago
related/dup of bug 37685, bug 55246

*** This bug has been marked as a duplicate of 37685 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.