Closed Bug 1115780 Opened 5 years ago Closed 5 years ago

Intermittent browser_wa_destroy-node-01.js | This test exceeded the timeout threshold. It should be rewritten or split up.

Categories

(DevTools Graveyard :: Web Audio Editor, defect)

All
Linux
defect
Not set

Tracking

(firefox35 unaffected, firefox36 unaffected, firefox37 fixed, firefox-esr31 unaffected)

RESOLVED FIXED
Firefox 37
Tracking Status
firefox35 --- unaffected
firefox36 --- unaffected
firefox37 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: KWierso, Assigned: jsantell)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

13:37:48 INFO - 3388 INFO TEST-START | browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js
13:37:49 INFO - -*-*- UserCustomizations (child): document created: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_destroy-nodes.html
13:37:49 INFO - -*-*- UserCustomizations (child): _injectInWindow
13:37:49 INFO - -*-*- UserCustomizations (child): principal status: 0
13:37:59 INFO - JavaScript warning: chrome://browser/content/devtools/d3.js, line 479: mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
13:38:00 INFO - -*-*- UserCustomizations (child): document created: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_destroy-nodes.html
13:38:00 INFO - -*-*- UserCustomizations (child): _injectInWindow
13:38:00 INFO - -*-*- UserCustomizations (child): principal status: 0
13:38:35 INFO - 3389 INFO checking window state
13:38:35 INFO - 3390 INFO Entering test
13:38:35 INFO - 3391 INFO Initializing a web audio editor pane.
13:38:35 INFO - 3392 INFO Adding tab: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_destroy-nodes.html
13:38:35 INFO - 3393 INFO Tab added and finished loading: http://example.com/browser/browser/devtools/webaudioeditor/test/doc_destroy-nodes.html
13:38:35 INFO - 3394 INFO Console message: [JavaScript Warning: "mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create" {file: "chrome://browser/content/devtools/d3.js" line: 479}]
13:38:35 INFO - 3395 INFO Waiting for event: 'start-context' on [Front for webaudio/conn266.child2/webaudioActor7].
13:38:35 INFO - 3396 INFO Waiting for event: 'navigate' on TabTarget:[object XULElement].
13:38:35 INFO - 3397 INFO Console message: [JavaScript Warning: "Unexpected value strokewidth parsing markerUnits attribute." {file: "chrome://browser/content/devtools/d3.js" line: 589}]
13:38:35 INFO - 3398 INFO Waiting for event: 'WebAudioEditor:UIInspectorNodeSet' on [object ChromeWindow].
13:38:35 INFO - 3399 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3400 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3401 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3402 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3403 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3404 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3405 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3406 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3407 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3408 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3409 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3410 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3411 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3412 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3413 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3414 INFO Console message: [JavaScript Warning: "Unexpected value strokewidth parsing markerUnits attribute." {file: "chrome://browser/content/devtools/d3.js" line: 589}]
13:38:35 INFO - 3415 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3416 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3417 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3418 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3419 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3420 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3421 INFO Console message: [JavaScript Warning: "Unexpected value strokewidth parsing markerUnits attribute." {file: "chrome://browser/content/devtools/d3.js" line: 589}]
13:38:35 INFO - 3422 INFO TEST-PASS | browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | All nodes should be GC'd except one gain, osc and dest node.
13:38:35 INFO - 3423 INFO TEST-PASS | browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | dest should be in graph
13:38:35 INFO - 3424 INFO TEST-PASS | browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | osc should be in graph
13:38:35 INFO - 3425 INFO TEST-PASS | browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | gain should be in graph
13:38:35 INFO - 3426 INFO TEST-PASS | browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | Only 3 nodes rendered in graph.
13:38:35 INFO - 3427 INFO TEST-PASS | browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | Only 2 edges rendered in graph.
13:38:35 INFO - 3428 INFO TEST-PASS | browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | InspectorView empty message should show if the currently selected node gets collected.
13:38:35 INFO - 3429 INFO Destroying the web audio editor.
13:38:35 INFO - 3430 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3431 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3432 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3433 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3434 INFO Console message: [JavaScript Warning: "Error in parsing value for 'text-anchor'. Declaration dropped." {file: "chrome://browser/content/devtools/webaudioeditor.xul" line: 0 column: 0 source: "left"}]
13:38:35 INFO - 3435 INFO Console message: [JavaScript Warning: "Unexpected value strokewidth parsing markerUnits attribute." {file: "chrome://browser/content/devtools/d3.js" line: 589}]
13:38:35 INFO - 3436 INFO Leaving test
13:38:35 INFO - 3437 INFO finish() was called, cleaning up...
13:38:35 INFO - 3438 INFO TEST-UNEXPECTED-FAIL | browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. - expected PASS
13:38:35 INFO - 3439 INFO TEST-OK | browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js | took 46351ms
13:38:35 INFO - 3440 INFO TEST-START | browser/devtools/webaudioeditor/test/browser_wa_first-run.js
Assignee: nobody → jsantell
This is based on a GC event, so extending the timeout seems ok in this case. Probably the cause of bug 1115779 as well.

try: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=c5fdf8f04091
Attachment #8541940 - Flags: review?(vporof)
Status: NEW → ASSIGNED
Comment on attachment 8541940 [details] [diff] [review]
1115780-destroy-audionode-test-fix.patch

Review of attachment 8541940 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/webaudioeditor/test/browser_wa_destroy-node-01.js
@@ +11,5 @@
>  
>  add_task(function*() {
> +  // Use a longer timeout as garbage collection event
> +  // can be unpredictable.
> +  requestLongerTimeout(2);

k lol
Attachment #8541940 - Flags: review?(vporof) → review+
https://hg.mozilla.org/mozilla-central/rev/56c2e6eea92a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 37
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.