Closed Bug 1115811 Opened 7 years ago Closed 4 years ago

tiscali.it doesn't redirect to mobile site

Categories

(Web Compatibility :: Mobile, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: niccolocantu94, Unassigned, NeedInfo)

References

()

Details

(Whiteboard: [country-it] [serversniff] [sitewait])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Mobile; rv:26.0) Gecko/26.0 Firefox/26.0
Build ID: 20141215131549

Steps to reproduce:

visit tiscali.it on Firefox OS and on Firefox for Android

B2G HTTP request:

GET / HTTP/1.1
Host: www.tiscali.it
User-Agent: Mozilla/5.0 (Mobile; rv:26.0) Gecko/26.0 Firefox/26.0

Firefox For Android HTTP request:

GET / HTTP/1.1
Host: www.tiscali.it
User-Agent: Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0




Actual results:

get desktop site 

HTTP response:

HTTP/1.1 200 OK
Content-Type: text/html



Expected results:

get desktop site 

expected HTTP response:

HTTP/1.1 302 Found
Location: http://m.tiscali.it
Confirmed from http://arewecompatibleyet.com/screenshots/?cctld=it#7
Contacted by twitter on the official account https://twitter.com/Mte90Net/status/548879607949426688
Whiteboard: [country-it] [serversniff] [sitewait]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Sent a new tweet to the Support twitter account.
Confirmed, it redirects to http://www.tiscali.it/
Screenshot: http://i.imgur.com/9UCxYoN.png
The problem but they have replied (in the tweet) months ago that are working on.
I'm not able to reproduce the issue. Mobile page is displayed, also navigation on the site displays the mobile version correctly.

Tested with:
Browser / Version: Firefox Mobile Nightly 61.0a1 (2018-04-09)
Operating System: Google Pixel (Android 8.0.0) - 1080 x 1920 pixels (~441 ppi pixel density), 
Samsung Galaxy S7 Edge (Android 7.0) - 1440 x 2560 pixels (~534 ppi pixel density)

Niccolò, feel free to reopen the issue if you can still reproduce.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(niccolocantu94)
Resolution: --- → FIXED
Priority: -- → P3
Added attachment with the mobile version.
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.