Closed Bug 1115915 Opened 6 years ago Closed 2 years ago

Loading large text log files is much slower on Firefox than Chrome

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 515447

People

(Reporter: jfrench, Unassigned)

References

Details

When I load a raw log on Treeherder on windows atm, it seems to take about 8-10 seconds to load the page on Firefox, whereas on Chrome it's pretty much instant.

I'm curious if anyone else sees this behavior on windows or another OS, or if it's just me. I've tried it on a couple of windows machines here.

I hadn't encountered this kind of delay loading raw logs in the past.

To reproduce:
o load/re-load a link like this in Chrome, and in Firefox
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-linux/1419679350/mozilla-central-linux-bm72-build1-build125.txt.gz

Expected:
The load times might be roughly the same.

Observed:
Chrome is pretty much instant, maybe a second. Firefox is ~8sec to load and the browser is pretty much MIA while it's loading (though I guess that is single threading).

My settings for both browsers are roughly defaults for each, give or take.

Just in case there have been any changes in how the content is being hosted that impacts Firefox.
Curious if e10s helps or hurts perf here.
This is a bug in Firefox Core rather than treeherder, moving.
Worth taking a look though :-)
Blocks: 1112352
Status: UNCONFIRMED → NEW
Component: Treeherder: Log Viewer → DOM
Ever confirmed: true
Priority: P3 → --
Product: Tree Management → Core
Version: --- → Trunk
Summary: Raw log load appears to be much slower on Firefox than Chrome → Loading large text log files is much slower on Firefox than Chrome
I'm almost positive we have a similar bug open for when this happened on TBPL.
(In reply to Nathan Froyd [:froydnj] [:nfroyd] from comment #3)
> I'm almost positive we have a similar bug open for when this happened on
> TBPL.

That's bug 762710 - about TBPL's parsed view, which stuffed the log content inside <pre>, whereas this is for the raw text files.
Well the HTML document which is created for raw text files is 

<html><head><link rel="alternate stylesheet" type="text/css" href="resource://gre-resources/plaintext.css" title="Wrap Long Lines"></head><body><pre>
{the contents of the file}
</pre></body></html>
Ha learn something every day :-)

Happy for you to dupe/tweak as needed,.
See Also: → 860492
Priority: -- → P5
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 515447
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.