Handle non-200 status codes in nr_proxy_tunnel.c

RESOLVED DUPLICATE of bug 1203503

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 1203503
3 years ago
2 years ago

People

(Reporter: ryan, Unassigned)

Tracking

34 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

Send HTTP CONNECT to proxy server that requires authentication


Actual results:

nr_socket_proxy_tunnel_read() will not understand the challenge and the connection will fail


Expected results:

nr_proxy_tunnel.c should understand challenge-response for HTTP authentication and allow the offering of credentials

Updated

3 years ago
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
I can't find nr_proxy_tunnel.c in our mozilla-central code base. Can you give a more details set of steps to reproduce your issue?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 2

3 years ago
Sorry, I forgot to add the dependency -- this depends on a patch under review and this bug was requested as part of the review.
Depends on: 949703

Updated

3 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---
Duplicate of this bug: 1216413
Whiteboard: [necko-backlog]
Closing in favor of bug 1203503, as that has the better description in it and the appropriate product and component set.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1203503
You need to log in before you can comment on or make changes to this bug.