Closed Bug 1115982 Opened 7 years ago Closed 4 years ago

unieuro.com / unieuro.it sends desktop site to Firefox OS

Categories

(Web Compatibility :: Mobile, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: niccolocantu94, Unassigned)

References

()

Details

(Whiteboard: [country-it][serversniff][sitewait])

User Agent: Mozilla/5.0 (Linux; Android 4.4; Nexus 5 Build/_BuildID_) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/30.0.0.0 Mobile Safari/537.36
Build ID: 20141215131549

Steps to reproduce:

visit unieuro.it


Actual results:

get desktop site


Expected results:

get mobile site, which is available on http://mobile.unieuro.it
This site intends to send mobile browsers to a mobile site, but doesn't know that Firefox OS devices are smartphones. Hence the browser on Firefox OS phones get desktop content instead of mobile.

The HTTP traffic analysis below shows how the sniffing works:

There's a significant difference in source code sent to the different browsers:
Smallest response has Content-Length: 28833
Largest response has Content-Length: 119375


Selected HTTP response headers (Firefox OS, Firefox on Android, Safari on iPhone):

Response for: 'Mozilla/5.0 (Mobile; rv:29.0) Gecko/29.0 Firefox/29.0'
Response Status: 200
content-length: 119375
content-type: text/html;charset=UTF-8

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 200
content-length: 28833
content-type: text/html;charset=UTF-8

Response for: 'Mozilla/5.0 (iPhone; CPU iPhone OS 6_0 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10A5376e Safari/8536.25'
Response Status: 200
content-length: 28833
content-type: text/html;charset=UTF-8
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: unieuro.com sends desktop site to Firefox OS → unieuro.com / unieuro.it sends desktop site to Firefox OS
Confirmed from http://arewecompatibleyet.com/screenshots/?cctld=it#30
Contacted by fb on the official account with a pm.
Whiteboard: [country-it][serversniff][sitewait]
Confirmed. It redirects to http://www.unieuro.it/online
Screenshot: http://i.imgur.com/b10yfR3.png
new pm on facebook because the site is not fixed on firefox os
Priority: -- → P5
Closing as we are not working on Firefox OS anymore.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.