If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash in NS_CycleCollectorSuspect3

RESOLVED DUPLICATE of bug 1137343

Status

()

Core
General
--
critical
RESOLVED DUPLICATE of bug 1137343
3 years ago
3 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({crash})

Trunk
All
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-a31964df-4b03-4cfb-a86a-737312141229.
=============================================================


not really sure about the steps to reproduce.

Bascially just opened Firefox 

Frame 	Module 	Signature 	Source
0 	XUL 	NS_CycleCollectorSuspect3 	obj-firefox/x86_64/dist/include/nsRefPtr.h
1 	XUL 	XPCWrappedNative::AddRef() 	obj-firefox/x86_64/dist/include/nsISupportsImpl.h
2 	XUL 	XPCWrappedNative::QueryInterface(nsID const&, void**) 	js/xpconnect/src/XPCWrappedNative.cpp
3 	XUL 	nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&) 	xpcom/glue/nsCOMPtr.cpp
4 	XUL 	mozilla::storage::AsyncStatement::~AsyncStatement() 	obj-firefox/x86_64/dist/include/nsCOMPtr.h
5 	XUL 	_ZThn8_N7mozilla7storage14AsyncStatement7ReleaseEv 	storage/src/mozStorageAsyncStatement.cpp
6 	XUL 	mozilla::storage::StatementData::~StatementData() 	obj-firefox/x86_64/dist/include/nsCOMPtr.h
7 	XUL 	mozilla::storage::AsyncExecuteStatements::notifyComplete() 	storage/src/mozStorageStatementData.h
8 	XUL 	mozilla::storage::AsyncExecuteStatements::Run() 	storage/src/mozStorageAsyncStatementExecution.cpp
9 	XUL 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
10 	XUL 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
11 	XUL 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
12 	XUL 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
13 	XUL 	nsThread::ThreadFunc(void*) 	xpcom/threads/nsThread.cpp
14 	libnss3.dylib 	_pt_root
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137343
You need to log in before you can comment on or make changes to this bug.