[v2.2] Fix test_rocketbar_add_collection failure

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RobertC, Assigned: RobertC)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
test_rocketbar_add_collection is failing on Jenkins because the newly added collection is not seen as installed.

http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.b2g-inbound.ui.functional.smoke/1843/HTML_Report/

The issue is not reproduced manually.
With automation the reproduction rate is 10 out of 10.

Issue requires further investigation.
(Assignee)

Updated

3 years ago
QA Whiteboard: [fxosqa-auto-s7]
(Assignee)

Comment 1

3 years ago
Created attachment 8542107 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27040

The test is failing because the installed_app() method no longer works for collection icons. I added a patch for this and started an adhoc run with the tests that seem to use the method.

http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/524/console
Attachment #8542107 - Flags: review?(martijn.martijn)
Comment on attachment 8542107 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27040

Sorry, I think I actually caused this failure by fixing bug 1094151.

I guess there are no more icons classes on the homescreen, apart from 'bookmark' and 'collection'?
Attachment #8542107 - Flags: review?(martijn.martijn) → review+
(Assignee)

Comment 3

3 years ago
Merged in master:
https://github.com/mozilla-b2g/gaia/commit/c0728f5ff3f021b788967ff17c3baa4770876290

I haven't seen other types of icons. We can handle those when we encounter them.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.