Closed Bug 1116140 Opened 5 years ago Closed 5 years ago

CSS order property (Flexbox) affects document tabbing sequence

Categories

(Firefox :: Untriaged, defect)

34 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 812687

People

(Reporter: mail, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

I rearranged a couple of elements using the CSS property order and tried tabbing through the document.

Live test case: http://medialize.github.io/ally.js/tests/browser-bugs/gecko-flexbox-order.html


Actual results:

The document tabbing sequence was altered by the order property and caused the tabbing sequence to be ordered.2, ordered.3, ordered.1

This behavior is reproducible in Firefox Nightly 37.0a1 (2014-12-20)


Expected results:

The document tabbing sequence should not be altered by the order property, the correct sequence is ordered.1, ordered.2, ordered.3
Dupe of bug 812687?
Flags: needinfo?(dholbert)
Yup.  (See last comments there in particular -- there's a proposal that the spec be changed to effectively match our behavior on this.)
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(dholbert)
Resolution: --- → DUPLICATE
Duplicate of bug: 812687
You need to log in before you can comment on or make changes to this bug.