Closed Bug 1116231 Opened 5 years ago Closed 5 years ago

Move "reader.parse-on-load." pref change observer back to Reader.js

Categories

(Firefox for Android :: Reader View, defect)

35 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 37

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

Looks like a mistake from the changes in bug 793920.
Attachment #8542252 - Flags: review?(bnicholson)
/r/1769 - Bug 1116231 - Move reader.parse-on-load. pref change observer back to Reader.js

Pull down this commit:

hg pull review -r 84b2b8daaf056f544174c174904400957aa8a94e
How did you notice that the wrong change was made? It looks like we should add an automated test so that we don't only notice the bustage after landing.
Flags: needinfo?(margaret.leibovic)
Attachment #8542252 - Flags: review?(mark.finkle)
/r/1769 - Bug 1116231 - Move reader.parse-on-load. pref change observer back to Reader.js
/r/1771 - Bug 1111142 - (Part 1) Turn aboutReader.js into an AboutReader module
/r/1773 - Bug 1111142 - (Part 2) Load AboutReader in a frame script on Fennec
/r/1775 - Bug 1111142 - (Part 3) Replace fennec-specific logic in AboutReader.jsm with messages

Pull down these commits:

hg pull review -r 28d2fe13d47b04073aca4d32d7c178bb263a7080
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #3)
> How did you notice that the wrong change was made? It looks like we should
> add an automated test so that we don't only notice the bustage after landing.

I noticed because I was moving this to another place in bug 1111142 :)

I agree, some automated tests would be good. We currently have a few basic reader mode tests for Android, but after the dust settles on the refactoring I'm doing, it would be good to get some shared xpcshell tests in toolkit. The fact that we're using modules should hopefully make test writing more pleasant!
Flags: needinfo?(margaret.leibovic)
(In reply to :Margaret Leibovic from comment #4)
> /r/1769 - Bug 1116231 - Move reader.parse-on-load. pref change observer back
> to Reader.js
> /r/1771 - Bug 1111142 - (Part 1) Turn aboutReader.js into an AboutReader
> module
> /r/1773 - Bug 1111142 - (Part 2) Load AboutReader in a frame script on Fennec
> /r/1775 - Bug 1111142 - (Part 3) Replace fennec-specific logic in
> AboutReader.jsm with messages
> 
> Pull down these commits:
> 
> hg pull review -r 28d2fe13d47b04073aca4d32d7c178bb263a7080

Gr, review board doesn't seem to handle building patches on top of patches from other bugs... I'll try to fix this.
Attachment #8542252 - Flags: review?(mark.finkle)
/r/1769 - Bug 1116231 - Move reader.parse-on-load. pref change observer back to Reader.js

Pull down this commit:

hg pull review -r 84b2b8daaf056f544174c174904400957aa8a94e
Attachment #8542252 - Flags: review?(bnicholson) → review+
https://hg.mozilla.org/mozilla-central/rev/9198ef9c7df6
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Attachment #8542252 - Attachment is obsolete: true
Attachment #8618982 - Flags: review+
Attachment #8618983 - Flags: review+
Attachment #8618984 - Flags: review+
Attachment #8618985 - Flags: review+
You need to log in before you can comment on or make changes to this bug.