Last Comment Bug 1116305 - Lightning 3.3.2 still speaks only English in TB 31.3.
: Lightning 3.3.2 still speaks only English in TB 31.3.
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: General (show other bugs)
: Lightning 3.3
: x86 Windows XP
-- normal (vote)
: 3.3.3
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
: 1164769 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-29 15:29 PST by jarmo
Modified: 2015-05-14 14:05 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
compare-locales.txt (220.51 KB, text/plain)
2015-01-02 03:45 PST, Philipp Kewisch [:Fallen]
no flags Details

Description User image jarmo 2014-12-29 15:29:28 PST
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

1. Updated a Finnish Thunderbird to version 31.0 and then installed an compatible Lightning add-on update (3.3). Calendar-related menus, labels, buttons etc. has changed in English. This is an earlier documented error.
2. Recently updated to TB 31.3.
2. Went to add-on manager and saw that there is a Lightning update (3.3.2, released December 27th) available. Told Thunderbird to update add-on, and then restarted Lightning.


Actual results:

When TB restarted, all the calendar-related components were still in English. Yes, Lightning 3.3.2 was installed.


Expected results:

According to the add-on page https://addons.mozilla.org/fi/thunderbird/addon/lightning/versions/?page=1#version-3.3.2 this update should correct the missing locales.

In Lightning 3.4 beta (for TB 32 beta, released August 18), 3.5 beta (for TB 33 beta, released September 23) and 3.6 beta (for TB 34 beta, released November 15), this error is resolved, but still the last Lightning release version 3.3.2 has this error.
Comment 1 User image [:MakeMyDay] 2015-01-01 05:12:41 PST
Confirming. The FI locale is missing in all version of 3.3.x branch and the problem seems not to be limited to FI locale.

A. Locales in 2.6.6 and in 3.4, 3.5, 3.6 betas, but not in 3.3.2:
FI, NB-NO, PT-PT

B. Locales in 3.3.2, but not in  3.4, 3.5, 3.6 betas:
BG, HR, KO

C. Locales not in 2.6.6 and 3.3.2, but in 3.4 beta (I assume those were new to 3.4, but they might have been new to 3.3 already without being shipped - needs being cross-checked):
ID, PA-IN, SQ, TR, UK

D. Locales from the dashboard, which weren't shipped in versions from 2.6.6 to 3.6:
AR, CY, GL, HE, KA, RO, SL

Philipp, I guess for A. and eventually C. we would need another 3.3.x release, while for B. and eventually D. at least a check on the build scripts / sign-off for the betas seems to be appropriate.
Comment 2 User image Philipp Kewisch [:Fallen] 2015-01-02 03:45:19 PST
Created attachment 8543256 [details]
compare-locales.txt

Any locale that was not signed off on the Thunderbird dashboard for tb31 is not included in Lightning 3.3.x. I made an exception in the other bug for gd and lt, but I had to find a green changeset on my own and manually compile the locale packages.

Lightning 3.3.x should contain the locales using these changesets:
https://l10n.mozilla.org/shipping/l10n-changesets?av=tb31

Anything thats not in Lightning but covered by that list is a mistake of the build script or me not adding it to shipped-locales. 

I've attached the compare-locales output from using those changesets with comm-esr31, incomplete locales are:

ar ast be bn-BD br el fi gd gl he hy-AM id lt nb-NO pa-IN pt-BR pt-PT rm ro si sl sq sr ta-LK tr uk vi

Maybe we should get a few more locales CC'd here so they can provide me with an updated changeset that is green, then I can put together the files manually once again.
Comment 3 User image Philipp Kewisch [:Fallen] 2015-01-02 04:12:02 PST
I've written everyone from above list an email that I had in my addressbook and given a deadline until January 9th.
Comment 4 User image [:MakeMyDay] 2015-01-25 02:30:04 PST
Philipp, did you receive any updated changesets on your request? Otherwise, I suggest to set this to wontfix for 3.3.x.

Did you already make l10n groups aware of combined shipment of TB/Lightning with TB38? To not have calendar localizations for all localized TBs would be a weired expirience for an in-product shipment.
Comment 5 User image Philipp Kewisch [:Fallen] 2015-01-25 06:01:04 PST
I'm going to release 3.3.3 in a few days, just waiting for one more locale who said he'd be done over the weekend.

Regarding TB38, I will give more info on this in the Thundebird Meeting on Tuesday and likely add a blog post afterwards. There isn't much time left and there are a lot of unknowns in the equation, so regarding l10n we might have to live with a mismatch in the set of locales. I don't think its fair to force the remaining localizers to translate the extra 2k (?) strings with only 12-18 weeks left.
Comment 6 User image Philipp Kewisch [:Fallen] 2015-01-28 15:12:44 PST
Lightning 3.3.3 was released with the extra locales. TB38 stuff will be discussed elsewhere.
Comment 7 User image bjoeahan 2015-05-14 14:05:30 PDT
*** Bug 1164769 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.