[Clock][FFOS7715 v2.1] Once timer alarm goes off after set a timer alarm of 1 minute, then go back into clock app and the timer page display abnormally

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
7 months ago

People

(Reporter: ffos_st, Assigned: vchen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sprd387730)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description:
Once timer alarm goes off after set a timer alarm of 1 minute, then go back into clock app and the timer page display abnormally

Device: 
SPRD 7715ea

Build Identifier: 
20141230114532

Steps to Reproduce:
1) Goto clock, set an timer alarm of a minute, then hit the home button

2) wait a minute, when timer alarm goes off, hit the home button and go back into clock app


Actual Result: 
The timer pager display abnormally (display superfluous seconds)

Expected Result:
The timer pager display abnormally

Repro frequency:
10/10,100%
(Reporter)

Updated

4 years ago
Whiteboard: sprd387730
Hi ffos_st 

I cannot reproduce this one with Flame or with SPRD 7715 device I have, could you help to provide a reproduce video?

Thanks for your help

Vance
Flags: needinfo?(ffos_st)
(Reporter)

Comment 2

4 years ago
Created attachment 8542451 [details]
bug video
Flags: needinfo?(ffos_st)
I see....allow me to slightly modify your reproduce steps:

1. Set a timer a 1 minutes, start the timer and press home key to back to homescreen
2. When the timer expire, press the Home key again to put the Timer prompt to background
3. Press the Clock icon in the homescreen to enter the Clock application
4. Notice that the timer countdown pick stays at strange seconds(26 or 23 seconds)

Assign this bug to me since i think it is a good first-time bug
Assignee: nobody → vchen
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Updated

4 years ago
Summary: [FFOS7715 v2.1] Once timer alarm goes off after set a timer alarm of 1 minute, then go back into clock app and the timer page display abnormally → [FFOS7715 v2.1] [Clock] Once timer alarm goes off after set a timer alarm of 1 minute, then go back into clock app and the timer page display abnormally
(Reporter)

Updated

4 years ago
Summary: [FFOS7715 v2.1] [Clock] Once timer alarm goes off after set a timer alarm of 1 minute, then go back into clock app and the timer page display abnormally → [Clock][FFOS7715 v2.1] Once timer alarm goes off after set a timer alarm of 1 minute, then go back into clock app and the timer page display abnormally
Hi ffos_st 

Seems like the following modification can fix this bug, please give it a try and let me know if you see other problems:

diff --git a/apps/clock/js/panels/timer/main.js b/apps/clock/js/panels/timer/main.js
index 4994977..c032796 100644
--- a/apps/clock/js/panels/timer/main.js
+++ b/apps/clock/js/panels/timer/main.js
@@ -164,6 +164,7 @@ Timer.Panel.prototype.dialog = function(opts = { isVisible: true }) {
 
 Timer.Panel.prototype.tick = function() {
   if (!this.timer || this.timer.remaining <= 0) {
+    this.nodes.time.textContent = "00:00:00";
     return;
   }
   this.update(this.timer.remaining);

Thanks

Vance
Flags: needinfo?(ffos_st)
(Reporter)

Comment 5

4 years ago
Hi Vance 

I did a try to use your modification, but it doesn't work;

then I try to do my modification, and it works to fix this bug, Do you think it is a good solution?

diff --git a/apps/clock/js/panels/alarm/active_alarm.js b/apps/clock/js/panels/alarm/active_alarm.js
index c9b5436..9ad030d 100644
--- a/apps/clock/js/panels/alarm/active_alarm.js
+++ b/apps/clock/js/panels/alarm/active_alarm.js
@@ -50,6 +50,14 @@ define(function(require) {
           break;
         case 'timer':
           this.onTimerFired(data, done);
+          // SPRD: bug 387730, the timer page display abnormally. start @{
+          Timer.singleton(function(err, timer) {
+            if (!err) {
+              timer.cancel();
+              timer.save();
+            }
+          });
+          // SPRD: bug 387730 end @}
           break;
         }
       });  


 Thanks

 ffos_st
Flags: needinfo?(ffos_st)
(In reply to ffos_st from comment #5)
> Hi Vance 
> 
> I did a try to use your modification, but it doesn't work;
> 
> then I try to do my modification, and it works to fix this bug, Do you think
> it is a good solution?
> 
> diff --git a/apps/clock/js/panels/alarm/active_alarm.js
> b/apps/clock/js/panels/alarm/active_alarm.js
> index c9b5436..9ad030d 100644
> --- a/apps/clock/js/panels/alarm/active_alarm.js
> +++ b/apps/clock/js/panels/alarm/active_alarm.js
> @@ -50,6 +50,14 @@ define(function(require) {
>            break;
>          case 'timer':
>            this.onTimerFired(data, done);
> +          // SPRD: bug 387730, the timer page display abnormally. start @{
> +          Timer.singleton(function(err, timer) {
> +            if (!err) {
> +              timer.cancel();
> +              timer.save();
> +            }
> +          });
> +          // SPRD: bug 387730 end @}
>            break;
>          }
>        });  
> 
> 
>  Thanks
> 
>  ffos_st

Hi ffos_st

Sorry I just realize I didn't give you the correct patch, but anyway your modification and mind are similar in concept, and I think your is better.

I didn't try your patch, but wouldn't that cause some changes in UI flow? Looks like when we press "Clock" icon to back to Clock app again, we will be brought to the Timer picker screen, now the count down screen? Is that the case?

Thanks

Vance
Flags: needinfo?(ffos_st)
(Reporter)

Comment 7

4 years ago
Hi Vance

yes, after use my patch, when we press "Clock" icon to back to Clock app again, we will be brought to the Timer picker screen, not display the count down screen.

Thanks

ffos_st
Flags: needinfo?(ffos_st)
I see...since this involves in UI change, ni UI team for further discussion, also ni Marcus to review the modification.


Hi Juwei -

Want your opinion about a UI behavior:

Here is the current design:

1. Start a timer
2. Back to idle screen and wait for the timer to expire
3. Once the timer expires, press the homekey to dismiss the timer prompt, then click on Clock icon on the homescreen
4. When the clock application launches, you will be brought to the countdown screen with a strange time on the countdown timer

What we propose here:

1. Start a timer
2. Back to idle screen and wait for the timer to expire
3. Once the timer expires, press the homekey to dismiss the timer prompt, then click on Clock icon on the homescreen
4. When the clock application launches, you will be brought to the timer picker screen to let you set the timer again.

The new proposed behavior is the same as iphone behavior, and we believe it does make sense since timer is expired, user should be brought to the picker screen, not the countdown timer screen

Please let us know what you think

Thanks

Vance
Flags: needinfo?(m)
Flags: needinfo?(jhuang)

Comment 9

4 years ago
Hi Vance,

From the video I saw the timer is not "dismissed", it's still going off but the time prompt is dismissed and put up to the notification tray.

I have two suggestions here, either way is good to me:

1. Dismiss the timer entirely when users press home button. And tap on clock app will go to the last screen where users stay on. (If u follow the same flow above, the screen would be time picker on timer)

It makes more sense to dismiss the timer at that moment because I think users won't expect the alert still go off when they know time's up.
Yet I think this solution will cause some technical changes, so I have another proposal:

2. When the alert goes off and users tap home key and tap the clock, the time prompt will show up again to ask users to stop the alert. When users stop the alert, the screen will go back to time picker on timer.

I think it would be also make sense that users have to stop the first timer then they can set up another one. Otherwise users can keep the first timer goes off and set another timer at the same time.


Let me know if it's feasible to you, thank you!
Flags: needinfo?(jhuang)
Either sounds good to me as well.
Flags: needinfo?(m)

Updated

4 years ago
Blocks: 1123554

Comment 11

7 months ago
Firefox OS is not being worked on
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.