[Flame][Browser]The "Try again" button is covered and device only shows a little bit blue icon in the lower right corner.

VERIFIED FIXED in 2.2 S4 (23jan)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lixia, Assigned: azasypkin)

Tracking

({regression})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(5 attachments, 1 obsolete attachment)

[1.Description]:
[Flame v2.2][Browser]The "Try again" button is covered and device only shows a little bit blue icon in the lower right corner when the prompt message "Server not found" pops up.
Attch:UI.png,completely.png and logcat_0345.txt.
Found time:03:45

[2.Testing Steps]: 
1.Input the correct password of wifi and tap "Ok" while this wifi has no internet connection.
2.Launch Browser app.
3.Open a website and wait.
** The prompt message "Server not found" will pop up.

[3.Expected Result]: 
3.The "Try again" button should display completely.

[4.Actual Result]: 
3.The "Try again" button is covered and device only shows a little bit blue icon.


[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        322ef5116a5827a30c9a3cd9b842449a9c66a5b3
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/67872ce17918
Build-ID        20141230010205
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free Test

[7.Note]:
If you input a wrong website address, this bug also exists.
(Reporter)

Comment 1

4 years ago
Posted file logcat_0345.txt (obsolete) —
(Reporter)

Updated

4 years ago
Attachment #8542922 - Attachment is obsolete: true
(Reporter)

Comment 2

4 years ago
Posted file logcat_0345.txt
(Reporter)

Comment 3

4 years ago
Posted image UI.png
(Reporter)

Comment 4

4 years ago
Posted image completely.png
Hi Ben, we have this truncation issue, could you help with this, thanks..
Flags: needinfo?(bfrancis)
Is this a regression?
Keywords: qawanted
(Reporter)

Comment 7

4 years ago
(In reply to Gregor Wagner [:gwagner] from comment #6)
> Is this a regression?

Hi Gregor,

    I can't repro this bug on Flame 2.1.

Best Regards.
Flags: needinfo?(anygregor)
Keywords: qawanted
(Reporter)

Comment 8

4 years ago
Flame 2.1 build:
Gaia-Rev        b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/99cea2c818f6
Build-ID        20150106001308
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.034709
FW-Date         Tue Jan  6 03:47:20 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(anygregor)
Confirmed regression.
Keywords: regression
QA Contact: pcheng
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20141229091935
Gaia: f56224529f88933bcffef89981dfe2d90fa98038
Gecko: 34d2758e4e80
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20141229102236
Gaia: 322ef5116a5827a30c9a3cd9b842449a9c66a5b3
Gecko: 2c0ef7315830
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia: 322ef5116a5827a30c9a3cd9b842449a9c66a5b3
Gecko: 34d2758e4e80

First Broken Gecko & Last Working Gaia - issue does NOT repro
Gaia: f56224529f88933bcffef89981dfe2d90fa98038
Gecko: 2c0ef7315830

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/f56224529f88933bcffef89981dfe2d90fa98038...322ef5116a5827a30c9a3cd9b842449a9c66a5b3

Caused by the patch for Bug 1105857.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Oleg, can you take a look at this issue please? Looks like the uplift for bug 1105857 might have caused this to occur.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(azasypkin)
(In reply to KTucker [:KTucker] from comment #11)
> Oleg, can you take a look at this issue please? Looks like the uplift for
> bug 1105857 might have caused this to occur.

Indeed, patch for bug 1105857 is the culprit (BB part of the patch). The fix is trivial, will provide it soon.

John, looking at the code I see that tv_apps should be affected by this issue too (see [1], I'm going to change "block" to "flex" to be in line with new BB styles), could you please confirm?

Thanks!

[1] https://github.com/mozilla-b2g/gaia/blob/b875c1ddb0a024d1d375d549d0a0268adb27ae80/tv_apps/smart-system/style/net_error.css#L13
Assignee: nobody → azasypkin
Blocks: 1105857
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.2?
Flags: needinfo?(azasypkin) → needinfo?(im)
(In reply to Oleg Zasypkin [:azasypkin] from comment #12)> 
> John, looking at the code I see that tv_apps should be affected by this
> issue too (see [1], I'm going to change "block" to "flex" to be in line with
> new BB styles), could you please confirm?

Thanks for the information. It is confirmed that tv had the same issue while net error showed.

> Thanks!
> 
> [1]
> https://github.com/mozilla-b2g/gaia/blob/
> b875c1ddb0a024d1d375d549d0a0268adb27ae80/tv_apps/smart-system/style/
> net_error.css#L13
Flags: needinfo?(im)
(In reply to John Hu [:johnhu][:johu][:醬糊小弟] from comment #13)
> Thanks for the information. It is confirmed that tv had the same issue while
> net error showed.
Okay, got it, thanks.

John and Ben, could you please review this simple patch?

I've just applied fix I outlined in comment 12, please let me know if you know about other places where the same thing is used (confirmation dialog with hidden button container) and I'll take care of it too.

Thanks!
Attachment #8547393 - Flags: review?(im)
Attachment #8547393 - Flags: review?(bfrancis)
Comment on attachment 8547393 [details] [review]
GitHub pull request URL

Looks good to me and it works correctly in the device. Thanks for this.
Attachment #8547393 - Flags: review?(im) → review+
Comment on attachment 8547393 [details] [review]
GitHub pull request URL

Thanks
Flags: needinfo?(bfrancis)
Attachment #8547393 - Flags: review?(bfrancis) → review+
Thanks for review guys, Treeherder is green, so landed.

Master: https://github.com/mozilla-b2g/gaia/commit/0cd0ad51bd9591ee4bf8c8210d8fbe688814d1a8
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+
This missed the v2.2 branching. Please request Gaia v2.2 approval for this when you get a chance.
Flags: needinfo?(azasypkin)
Target Milestone: --- → 2.2 S4 (23jan)
Comment on attachment 8547393 [details] [review]
GitHub pull request URL

Thanks Ryan!

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1105857
[User impact] if declined: user won't be able to trigger "try again" action in net-error dialog for both phone and tv systems. Eg. when no internet available through wifi connection or server isn't known, so pretty frequent case.
[Testing completed]: yes, manual testing
[Risk to taking this patch] (and alternatives if risky): very small, single-line targeted CSS-only change
[String changes made]: n/a
Flags: needinfo?(azasypkin)
Attachment #8547393 - Flags: approval-gaia-v2.2?
Attachment #8547393 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been successfully verified on Flame v2.2.
See attachment: verified_v2.2.np4
Reproduce rate: 0/5

Flame 2.2 build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150114002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150114.040029
FW-Date         Wed Jan 14 04:00:40 EST 2015
Bootloader      L1TC000118D0
Posted image verified_v2.2.png
This issue is verified fixed on Flame Master.

Result: "Try again" button is displayed properly on "Server not found" screen.
 
Device: Flame Master
BuildID: 20150121010204
Gaia: 5e98dc164b17fd6decb48a9eaddef0e55b82e249
Gecko: 540077a30866
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 ( Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Oleg, should we land this in v2.0m as well?
Flags: needinfo?(azasypkin)
(In reply to Julien Wajsberg [:julienw] from comment #24)
> Oleg, should we land this in v2.0m as well?

Nope, BB part of the patch for bug 1105857 that was the culprit for this bug wasn't included in v2.0m patch.
Flags: needinfo?(azasypkin)
You need to log in before you can comment on or make changes to this bug.