Spotify Web Player crashes with Async Init enabled

RESOLVED FIXED in Firefox 37

Status

()

Core
Plug-ins
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Eric Fowler, Assigned: aklotz)

Tracking

37 Branch
mozilla38
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox36 unaffected, firefox37 fixed, firefox38 fixed)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150103030215

Steps to reproduce:

I have e10s enabled and my current build is:
Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20150103030215 CSet: 57e4e9c33bef

With the new setting of dom.ipc.plugins.asyncInit set to true, going to this page:
https://play.spotify.com/browse
as an already logged in user causes the browser to crash.


Actual results:

Here is the crash report from when loading: https://play.spotify.com/browse

https://crash-stats.mozilla.com/report/index/7abf9a76-bba4-4bc7-a3d3-54cc02150103


Expected results:

The page will load without crashing, with no audio playing.
(Reporter)

Updated

3 years ago
Crash Signature: https://crash-stats.mozilla.com/report/index/7abf9a76-bba4-4bc7-a3d3-54cc02150103
(Reporter)

Updated

3 years ago
Blocks: 1116806

Updated

3 years ago
Crash Signature: https://crash-stats.mozilla.com/report/index/7abf9a76-bba4-4bc7-a3d3-54cc02150103 → [@ mozilla::Monitor::Lock() ]

Updated

3 years ago
Flags: needinfo?(aklotz)
Assignee: nobody → aklotz
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(aklotz)
(Reporter)

Comment 1

3 years ago
Still occurring today with e10s enabled:
Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0 ID:20150109030224 CSet: b3f84cf78dc2

But I did notice that with e10s disabled the crash doesn't occur with Async Init enabled, just fyi.
Thanks for the URL, Eric. I'm currently testing a fix.
(I must have written that code while I was sick with the flu!)
Created attachment 8548432 [details] [diff] [review]
Clean up handling of plugin entry points on Linux
Comment on attachment 8548432 [details] [diff] [review]
Clean up handling of plugin entry points on Linux

This patch fixes and reorganizes some stuff in the linux NP_Initialize.

I also removed some instances of NS_PLUGIN_INIT_PENDING when it was inappropriate to return that value. NS_PLUGIN_INIT_PENDING is really meant only for NPP_New, not NP_Initialize.

I also renamed mAsyncInitPluginFuncs to mNPPIface since it must now be used in some sync init places as well.
Attachment #8548432 - Flags: review?(jmathies)

Updated

3 years ago
Attachment #8548432 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/590d6f515541
https://hg.mozilla.org/mozilla-central/rev/590d6f515541
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Comment on attachment 8548432 [details] [diff] [review]
Clean up handling of plugin entry points on Linux

Approval Request Comment
[Feature/regressing bug #]: asynchronous plugin initialization
[User impact if declined]: feature won't be testable with aurora on linux
[Describe test coverage new/current, TBPL]: on m-c, plugin tests also pass with asyncInit activated on try
[Risks and why]: Low, changes are limited in scope and have been tested under both sync and async configurations
[String/UUID change made/needed]: None
Attachment #8548432 - Flags: approval-mozilla-aurora?
Comment on attachment 8548432 [details] [diff] [review]
Clean up handling of plugin entry points on Linux

Approving to get asyncInit testing on Linux on Aurora and to keep our options open wrt shipping this feature. Aurora+
Attachment #8548432 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
status-firefox36: --- → unaffected
status-firefox37: --- → affected
status-firefox38: --- → fixed
https://hg.mozilla.org/releases/mozilla-aurora/rev/c74b831b8c04
status-firefox37: affected → fixed

Comment 10

3 years ago
Seems to be back 

https://bugzilla.mozilla.org/show_bug.cgi?id=1128255


https://crash-stats.mozilla.com/report/index/0411598b-fade-47a4-8e2a-0c15b2150219

https://crash-stats.mozilla.com/report/index/92779ab1-0f05-4cf9-b905-7b5e82150212
(In reply to Ryan from comment #10)
> Seems to be back 
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=1128255
> 
> 
> https://crash-stats.mozilla.com/report/index/0411598b-fade-47a4-8e2a-
> 0c15b2150219
> 
> https://crash-stats.mozilla.com/report/index/92779ab1-0f05-4cf9-b905-
> 7b5e82150212

Same signature but a different bug.
You need to log in before you can comment on or make changes to this bug.