Repaint & render problems within browser window, toolbars, menu bars (everything except the title bar)

RESOLVED DUPLICATE of bug 77282

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 77282
17 years ago
14 years ago

People

(Reporter: earthsound, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
BuildID:    2001112009
I'm using build 0.9.6 on Winblows 98 with 64MB RAM. 

After clicking on a CNN.com link from the CNN.com sidebar panel, Mozilla's 
rendering/repainting is messed up (see attachment). I am able to reproduce it 
>90%, but not 100% of the time. I have also seen this behavior on other URLs, 
and will report those as I run across them. Also, if Chatzilla is open while 
this bug pops up, it's rendering is mucked up, as well. Everything from the 
menu bar, toolbars, Sidebar panel, navigation window area & even status bar get 
messed up. When cookie alerts pop up, they are unreadable. Web pages with 
scroll bars can be scrolled, but the text is smeared up and down the screen, 
causing the black hair-looking phenomena appearing at the bottom of the 
attached screenshot. I haven't found a workaround other than closing and 
relaunching Mozilla. The attached screenshot is of 
http://www.cnn.com/2001/WORLD/asiapcf/central/11/23/ret.afghan.konduz/index.html
 reached via the CNN.com sidebar panel. 

Reproducible: Most of the time
Steps to Reproduce:
I've reproduced it >95% of the time by
1. Opening Mozilla
2. Opening the Sidebar (adding the CNN.com panel if not already there)
3. Click on a link in the CNN.com panel

Actual Results:  The rendering/repainting is messed up, although pages will 
load, menu bar can be interacted with (but you can't see what you're doing, as 
it's unreadable), scrollbar can be scrolled (though you can't see it, either), 
sidebar panels can be opened/closed (you guessed it, they're illegible, too) & 
everything else appears to be unaffected except the rendering/repainting. 
Everything almost looks like it's loading on top of the previously loaded 
content, w/o the old content getting "painted away".

Expected Results:  Load the page as normal.
(Reporter)

Comment 1

17 years ago
Created attachment 59061 [details]
screenshot of cnn.com page rendered after this bug kicks in

compare this to the IE5.5 rendering of same page
(Reporter)

Comment 2

17 years ago
Created attachment 59062 [details]
screenshot of same cnn.com page as rendered by IE5.5
(Reporter)

Comment 3

17 years ago
Created attachment 59063 [details]
Screenshot of chatzilla after bug kicks in
(Reporter)

Comment 4

17 years ago
Created attachment 59064 [details]
screenshot of Mozilla after bug kicked from a link in bookmark's Sidebar panel

This screenshot was taken after I visited
http://msdn.microsoft.com/library/default.asp?url=/nhp/Default.asp?contentid=28000443
from:
Sidebar>Bookmarks>Mozilla Project>Developer Information>User interface
design>Microsoft User Experience and Interface Design Resources
(Reporter)

Comment 5

17 years ago
The last occurance, with the Microsoft page, didn't kick in until I began 
scrolling the bottom-right frame from left to right (with the Sidebar panel 
open, the remaining width caused the right frame (with the "User Interface" 
beginning) to pop up a bottom scrollbar. These steps have been reproducible, 
but not 100%.

Comment 6

17 years ago
Worksforme on 2001112203, Win98. The kind of problems you see usually come from
corrupted/dated application files. Did you install 0.9.6 without uninstalling
the previous installation? If yes, uninstall the current installation (from the
Control Panel) and delete the \program files\mozilla.org directory, then
re-install. Otherwise, try a new profile (shutdown Mozilla completely, then
start its Profile Manager). Most of the times, a new profile will cure the problem.
(Reporter)

Comment 7

17 years ago
There was no previous installation on this computer. I tried shutting down 
Mozilla and running it's Profile Manager, deleted the default profile & created 
a new one. The problem was still there. Next, I removed Mozilla, via the 
Control Panel, deleted the entire mozilla.org folder, and reinstalled with the 
stub-installer. The problem is still there. The next attachment is a screenshot 
of a cnn.com page I clicked to from the CNN.com panel, on the latest, *fresh* 
install. Any other suggestions?
(Reporter)

Comment 8

17 years ago
Created attachment 59074 [details]
Screenshot of CNN.com page from panel after fresh install

This screenshot was taken *after* I deleted the default profile, created a new
profile, deleted Mozilla via the Control Panel, deleted the entire mozilla.org
folder, installed a fresh Mozilla via the net stub installer, deleted the
default profile again, and created a new one. As you can see, the problem is
still there...

Comment 9

17 years ago
Reporter: In step 3, what does "adding the CNN.com panel" mean?
(You mean the normal Mozilla sidebar displayed by selecting "Sidebar"
in the "View" menu, don't you? Or does CNN has its own sidebar thingy?)

Comment 10

17 years ago
reminds me of the screenshots in bug 77282.
Reporter: What kind of graphics card do you have there?
(Reporter)

Comment 11

17 years ago
> Svante asked:
> 
> "Reporter: In step 3, what does "adding the CNN.com panel" mean?
> (You mean the normal Mozilla sidebar displayed by selecting "Sidebar"
> in the "View" menu, don't you? Or does CNN has its own sidebar thingy?)"

In step 2, "adding the CNN.com panel if not already there" is done by clicking
(within the Sidebar) Tabs>Customize Sidebar...>Sidebar Directory>CNN.com, then
clicking Add & OK.

> R.K.Aa asked:
> "Reporter: What kind of graphics card do you have there?"

This computer has an ATI Rage Pro AGP 2X, chip type is Mach64: RagePro, software
version: 5.22-C90
(Reporter)

Comment 12

17 years ago
Also, the gfx card has 8MB of RAM and I have just updated the driver to a more
recent version...will see if I can duplicate this bug. Hopefully it was just the
ATI drivers. *shrug*

Comment 13

17 years ago
resolving as dup of bug 77282 based on screenshots and card-type.

*** This bug has been marked as a duplicate of 77282 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.