All users were logged out of Bugzilla on October 13th, 2018

Declare that MacApplicationDelegate implements NSFileManagerDelegate protocol to fix -Wincompatible-pointer-types warning

RESOLVED DUPLICATE of bug 1117635

Status

()

RESOLVED DUPLICATE of bug 1117635
4 years ago
4 years ago

People

(Reporter: cpeterson, Assigned: cpeterson)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 years ago
This patch fixes the following clang warning about MacApplicationDelegate pointer being passed to setDelegate even though it doesn't declare that is implements the NSFileManagerDelegate protocol:

toolkit/xre/MacApplicationDelegate.mm:93:22 [-Wincompatible-pointer-types] incompatible pointer types sending 'MacApplicationDelegate *' to parameter of type 'id<NSFileManagerDelegate>'
(Assignee)

Comment 1

4 years ago
oops
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1117635
You need to log in before you can comment on or make changes to this bug.