[FFOS7715 v2.1][STK]USAT case 27.22.7.5.1 USER ACTIVITY EVENT SEQ 1.1 fail,Press any key,no ENVELOPE EVENT DOWNLOAD -USER ACTIVITY

RESOLVED DUPLICATE of bug 1126687

Status

Firefox OS
RIL
RESOLVED DUPLICATE of bug 1126687
3 years ago
3 years ago

People

(Reporter: jinghua.xing, Assigned: jinghua.xing)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.4 wontfix, b2g-v2.0 wontfix, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [sprd390814])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
[Testing Steps     ]:USAT case 27.22.7.5.1 USER ACTIVITY EVENT SEQ 1.1  EVENT DOWNLOAD -USER ACTIVITY

[Expected Result  ]:case pass

[Test Result      ]:Press any key,no ENVELOPE EVENT DOWNLOAD -USER ACTIVITY
(Assignee)

Updated

3 years ago
Whiteboard: [sprd390814]
(Assignee)

Comment 1

3 years ago
In 3GPP TS 51.010-4
Case request return: D6 07 19 01 04 82 02 82 81
Truly return:         D6 07 82 02 82 81 99 01 04

But in ETSI TS 101 267, it also say the Event list tag can be 99 or 19.

What should we do with this case?
(Assignee)

Comment 2

3 years ago
And does the difference between the tags' order of the truly returned and the requested can cause the case failed?
Flags: needinfo?(sku)
(Assignee)

Comment 3

3 years ago
As in the protocol ETSI TS 101 267, in the ENVELOPE EVENT DOWNLOAD returned, the Event list tag should be placed before the Device identities tag. Do I understand this right?
Flags: needinfo?(frsela)
(Assignee)

Comment 4

3 years ago
Created attachment 8544439 [details] [diff] [review]
stk_event.patch

I have made a patch for this issue. Can you help me review it?

Thank you.
Attachment #8544439 - Flags: review?(frsela)

Comment 5

3 years ago
Comment on attachment 8544439 [details] [diff] [review]
stk_event.patch

Review of attachment 8544439 [details] [diff] [review]:
-----------------------------------------------------------------

Change to proper owner for review.
Attachment #8544439 - Flags: review?(frsela) → review?(echen)

Comment 6

3 years ago
Hi Jinghua:
 After checking 3GPP TS 11.14, event list should come before device identities (see section 11).
But for tag part, both 19 or 99 are okay for Event list tag.

Hence, I think you patch should be able to work properly.


Hi Edgar,
 Since this involves the change in ril_worker.js, could you please help review it?
Flags: needinfo?(sku)

Comment 7

3 years ago
Change to proper component.
Component: Gaia → RIL
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM

Comment 8

3 years ago
(In reply to shawn ku [:sku] (OOO 01/06 ~ 01/09) from comment #6)
> Hi Jinghua:
>  After checking 3GPP TS 11.14, event list should come before device
> identities (see section 11).
> But for tag part, both 19 or 99 are okay for Event list tag.
> 
> Hence, I think you patch should be able to work properly.
> 
> 
> Hi Edgar,
>  Since this involves the change in ril_worker.js, could you please help
> review it?

Sure I will take a look. Thank you.
Flags: needinfo?(frsela)

Updated

3 years ago
Blocks: 791161

Comment 9

3 years ago
Comment on attachment 8544439 [details] [diff] [review]
stk_event.patch

Review of attachment 8544439 [details] [diff] [review]:
-----------------------------------------------------------------

Patch looks good, but please help to generate a HG patch by following below link,
https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F

Thank you. :)
Attachment #8544439 - Flags: review?(echen) → feedback+

Comment 10

3 years ago
Hi Jinghua, I assume you will handle this bug, otherwise please feel free to kick back to me, thank you.
Assignee: nobody → Jinghua.Xing

Updated

3 years ago
status-b2g-v1.4: --- → wontfix
status-b2g-v2.0: --- → wontfix
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected

Updated

3 years ago
Blocks: 1123554
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1126687
You need to log in before you can comment on or make changes to this bug.