Closed Bug 1117765 Opened 5 years ago Closed 5 years ago

Disabling OpenH264 doesn't suppress the download/update?

Categories

(Core :: WebRTC, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla37

People

(Reporter: benjamin, Assigned: spohl)

Details

Attachments

(1 file)

On fx-team, Richard Z reports that setting the pref media.gmp-gmpopenh264.enabled;false still causes the OpenH264 module to be downloaded.

If this is true, it is incorrect behavior. Disabling the plugin should disable both use and download/update of the plugin (for consistency, it should perhaps also delete versions which are already downloaded, though I'm less sure about this).

I'm going to give this to spohl since he's currently working on bug 1089867 which is very related.
Alexandra, I understand you are QA for WebRTC: could you try reproducing this: set the pref disabled before launching Firefox for the first time with a new profile (by e.g. editing user.js) and see whether OpenH264 is downloaded?
Assignee: nobody → spohl.mozilla.bugs
Flags: needinfo?(alexandra.lucinet)
OS: Linux → All
Hardware: x86_64 → All
Attached patch PatchSplinter Review
From [1] I can confirm that we're not currently checking media.gmp-gmpopenh264.enabled for downloads/installs of the OpenH264 module, only media.gmp-gmpopenh264.autoupdate. This doesn't directly affect EME since we were already planning to check for the enabled pref there (see bug 1089867 comment 23), but I'm curious whether or not we also need the autoupdate pref for EME. Will follow up in bug 1089867.

[1] http://mxr.mozilla.org/mozilla-central/source/toolkit/modules/GMPInstallManager.jsm#437
Attachment #8544054 - Flags: review?(benjamin)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8544054 - Flags: review?(benjamin) → review+
https://hg.mozilla.org/mozilla-central/rev/e7d6c779dc48
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> Alexandra, I understand you are QA for WebRTC: could you try reproducing
> this: set the pref disabled before launching Firefox for the first time with
> a new profile (by e.g. editing user.js) and see whether OpenH264 is
> downloaded?

Indeed, with yesterday's Nightly (2015-01-05), OpenH264 is downloaded despite media.gmp-gmpopenh264.enabled pref is set to false. With latest Nightly (Build ID: 20150106030201), this issue is no longer reproducible. Verified as fixed on Mac OS X 10.9.5, Windows 7 64-bit and Ubuntu 12.03 32-bit.
Status: RESOLVED → VERIFIED
Flags: needinfo?(alexandra.lucinet)
You need to log in before you can comment on or make changes to this bug.