Investigate test_call_log_groups failure

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
6 months ago

People

(Reporter: RobertC, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [xfail])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.ui.functional.non-smoke.1/87/HTML_Report/

test_call_log_groups is failing on Jenkins. On local device it fails constantly (5 out of 5). The issue cannot be reproduced manually.

From the screenshot it looks like the calls are in the wrong order.
(Reporter)

Updated

4 years ago
QA Whiteboard: [fxosqa-auto-s7+]
(Reporter)

Comment 1

4 years ago
Created attachment 8544561 [details]
call_log.png

I investigated this further, but cannot find the issue seen in the test run. 
Gabriele or Anthony, can you please take a look at the attachments? Maybe you can find the problem.

Below are the links to the test and the insert methods:
https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_call_log_groups.py
https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/gaia_test.py#L381
https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/mocks/mock_call.py
Flags: needinfo?(gsvelto)
Flags: needinfo?(anthony)
(Reporter)

Comment 2

4 years ago
Created attachment 8544562 [details]
logcat.txt
(Reporter)

Comment 3

4 years ago
Created attachment 8544563 [details]
2584670174dsitanleecreR.sqlite
I'm not involved with Dialer that much so I'll let Gabriele take a look.
Flags: needinfo?(anthony)
This is most likely caused by bug 1112577. Let's check again once I land the fix for that one.
Depends on: 1112577
Flags: needinfo?(gsvelto)
(Reporter)

Updated

4 years ago
QA Whiteboard: [fxosqa-auto-s7+] → [fxosqa-auto-from-s7] [fxosqa-auto-s8]
(Reporter)

Updated

4 years ago
Whiteboard: [xfail]
(Reporter)

Updated

4 years ago
QA Whiteboard: [fxosqa-auto-from-s7] [fxosqa-auto-s8] → [fxosqa-auto-from-s7] [fxosqa-auto-from-s8] [fxosqa-auto-s9]
(Reporter)

Updated

4 years ago
Assignee: robert.chira → nobody
QA Whiteboard: [fxosqa-auto-from-s7] [fxosqa-auto-from-s8] [fxosqa-auto-s9] → [fxosqa-auto-from-s6] [fxosqa-auto-from-s7] [fxosqa-auto-from-s8] [fxosqa-auto-dropped-s9]
Robert, can you check if this is still an issue? I've landed bug 1112577 which should have solved the issue here.
Flags: needinfo?(robert.chira)
Robert has left the project. Stealing his NI. Started adhoc job with 100 tries: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/703/console
Flags: needinfo?(robert.chira) → needinfo?(jlorenzo)
It looks like it's still failing; I think you can stop the job right away. We'll need to investigate this in detail.
Right, I stopped the job. Let me check how's it going locally.
Perma failing. I see exactly the same behavior as in the screenshot attached :s

FWIW, we inject the call log entries with:
> window.wrappedJSObject.CallLogDBManager.add(callLogEntry);

and we add them not in chronological order; today is added before yesterday which is before 2014, itself before 2013: https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/dialer/test_call_log_groups.py#L30

Should this behavior be okay with the new CallLogDBManager?
Flags: needinfo?(jlorenzo) → needinfo?(gsvelto)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #10)
> Should this behavior be okay with the new CallLogDBManager?

I thought this was due to a race but apparently it is not. It must be an issue in the call log database logic, this is still valid then.
Flags: needinfo?(gsvelto)
Afaik, this is also an issue on mozilla-central, so removing the [v2.2] part of the summary.

Gabriele, do we need to recheck if this is still an issue? Or do you expect this to be still a problem?
Flags: needinfo?(gsvelto)
Summary: [v2.2] Investigate test_call_log_groups failure → Investigate test_call_log_groups failure
I think this is an instance of bug 1151627 so it should still be a problem. I haven't time to fix that one yet but I hope to be able to before the end of June.
Flags: needinfo?(gsvelto)
Depends on: 1151627

Comment 14

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.