Deleted email content shows up in sent message after Thunderbird crash

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: info, Unassigned)

Tracking

({privacy})

x86_64
Windows 7
privacy

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141105223254

Steps to reproduce:

Spent quite a while writing an e-mail message, which included pasted text (Ctl-V) and HTML links. Deleted and revised the e-mail 2 or 3 times over a 12 hour period. Then my computer crashed. Luckily, the open composition was found in Drafts directory. I continued editing the e-mail, and then sent it, with a cc to myself (which is unusual for me, but in this case I needed it). 


Actual results:

When I received the email, ALL of the previous edits that had been deleted were in the sent message. Repeat:  ALL OF THE PREVIOUSLY DELETED TEXT (mostly copied Ctl-V text and some HTML links) were IN THE SENT MESSAGE, even though I had deleted them in much earlier versions of the composition. I checked my Sent directory, and indeed, it only showed my last revision of the e-mail. NONE of the old, deleted text was (visibly or knowingly) sent. Somehow, deleted text from earlier edits of an email composition were INTERNALLY SAVED by Thunderbird and SENT with the visibly sent text. 


Expected results:

Previously-deleted text should NOT be sent with an email!!! We know that deleted text sits in a Windows buffer, which can be called back via Ctl-Z. It appears that, somehow, Thunderbird reached into that "Ctl-Z buffer" and added previously deleted text to an e-mail message. Or??? I have no idea. But this is the weirdest PC error I've ever seen in my 30 years using PCs. Absolutely the weirdest, and probably the most DANGEROUS error, I've ever seen. Indeed, the deleted text should NOT have been sent, and has caused me profound embarrassment.
(Reporter)

Comment 1

4 years ago
ADDED 5 Jan 9:30AM

It's gets worse. I first checked my email on Earthlink's website (which is my IP) using their Web Mail client. This is where I saw all the previously-deleted text.

But I just checked my Thunderbird client, and there is NO DELETED TEXT on the incoming message. Only the email I visibly sent is visible on the Thunderbird-received e-mail. It looks fine on Thunderbird.

I'm not a programmer, but I do know that if "old deleted text" shows up in my Earthlink Web Mail server, then "old deleted text" was SENT with the email.

I don't know how it was sent, where it was hiding, or why it was there .... but clearly IT IS there, otherwise Earthlink's mail server would not have displayed it.

Again, this is a VERY DANGEROUS BUG, and probably doesn't happen very often, and if it does happen, many would not even know it.

Updated

4 years ago
Summary: Deleted Email Text Shows Up In Sent Message (Bizarre Error) → Deleted Email Content Shows Up In Sent Message after Crash
Josh,
was this an imap account?
Severity: normal → major
Flags: needinfo?(info)
Keywords: privacy
Summary: Deleted Email Content Shows Up In Sent Message after Crash → Deleted email content shows up in sent message after Thunderbird crash
Whiteboard: [closeme 2016-06-25]
(Reporter)

Comment 3

3 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #2)
> Josh,
> was this an imap account?

no, it's a POP account. I've not seen this bug since then. But then, I've not been looking for it.
Thanks for the update. If you see the problem again, please reopen the bug report
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Message Compose Window → Backend
Flags: needinfo?(info)
Product: Thunderbird → MailNews Core
Resolution: --- → FIXED
Whiteboard: [closeme 2016-06-25]
Version: 31 Branch → 31
You need to log in before you can comment on or make changes to this bug.