[Settings][Internet Sharing / Hotspot] Hotspot settings can be accessed while hotspot is enabled causing changes to not take effect until toggling the hotspot off and back on

VERIFIED FIXED in 2.2 S4 (23jan)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: mancas)

Tracking

({regression})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-Daily-Testing])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Description:
In 2.2 you are able to change a hotspot's settings after the hotspot has been turned on. These changes do not take effect until you toggle the hotspot off and back on. There is no warning about this and users may make a change and then encounter what they will interpret as broken functionality. 
This is opposed to 2.1 where the option to change the settings is greyed out / inaccessible until you toggle the hotspot to the off position insuring that all changes will be accurately reflected.


Repro Steps:
1) Update a Flame to 20150105010205
2) On test device enable a Wi-Fi hotspot
3) Enter Hotspot Settings and change name
4) On another device search wi-fi networks
5) Observe the Hotspot's original name
6) On the test device toggle the hotspot off and back on
7) On the other device (after a brief pause) refresh the available wi-fi networks.

Optional Additional Steps
8) On the test device enter the hotspot settings and change the password
9) On the other device attempt to connect to the created hotspot using the new password

Actual:
The changes in Hotspot settings are not reflected until toggling it off and on. While the other device can still connect even with different hotspot names being reflected - changing the password and using the new password (without toggling) will prevent the other device from connecting eventually resulting in an error message

Expected:
The changes will be reflected after being made without toggling
<OR> - the user will not be able to make changes with the hotspot toggled on
<OR> - a warning message informing users the must toggle hotspot to enact changes

Environmental Variables:
Device: Flame Master
Build ID: 20150105010205
Gaia: c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko: 636498d041b5
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (Master)
Firmware Version: V18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 5/5
See attached: Logcat
(Reporter)

Updated

4 years ago
Flags: needinfo?(pbylenga)
Functional regression of a core feature.

Requesting a window.
blocking-b2g: --- → 2.2?
Flags: needinfo?(pbylenga)
QA Contact: jmercado
(Assignee)

Updated

4 years ago
Assignee: nobody → b.mcb
(Assignee)

Comment 2

4 years ago
Posted file Proposed patch
Hey Arthur, I've made a first approach which disable all the inputs in the hotspot settings panel if the wifi-hotspot is enabled. This could give to the user the possibility of see the current password as well as the current settings.

However, we can disable the access to this panel by adding the aria-disabled attribute to the list element that handle the navigation.

Also, the regression-window is not necessary from my point of view since this is easy to fix and the cause of this issue is a refactor that unified all the styles inside the app (using a tag instead buttons)
Attachment #8545193 - Flags: review?(arthur.chen)
(Assignee)

Comment 3

4 years ago
Posted image hotspot-settings-disabled.png (obsolete) —
Removing the regressionwindow-wanted tag per comment 2.  I was almost done with the window and will keep the information set aside if it is determined that this is still desired later.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 5

4 years ago
Triage: regression, blocking.
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8545193 [details] [review]
Proposed patch

Thanks for working on the issue. This is a regression and the behavior before was that when Wi-Fi hotspot is enabled, the list item for hotspot settings is disabled. As users are able to check the SSID and security settings from the internet sharing panel, I think it is fine just disabling the list item.
Attachment #8545193 - Flags: review?(arthur.chen)
(Assignee)

Comment 7

4 years ago
Attachment #8545205 - Attachment is obsolete: true
(Assignee)

Comment 8

4 years ago
Comment on attachment 8545193 [details] [review]
Proposed patch

Arthur, the patch is working now, as expected.

Thanks!
Attachment #8545193 - Flags: review?(arthur.chen)
Comment on attachment 8545193 [details] [review]
Proposed patch

r=me, thanks!
Attachment #8545193 - Flags: review?(arthur.chen) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/47972cd187a9ee3dbdf455fec214646ce3490c4f

Please request Gaia v2.2 approval on this when you get a chance.
Flags: needinfo?(b.mcb)
Keywords: checkin-needed
Target Milestone: --- → 2.2 S4 (23jan)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

4 years ago
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Caused by a refactor that set up the same look&feel in the whole app
[User impact] if declined: User can change the hotspot settings with no effect until the feature is switch off and on.
[Testing completed]: Manual test
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: No
Flags: needinfo?(b.mcb)
Attachment #8551157 - Flags: approval-gaia-v2.2?
Attachment #8551157 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Flame 3.0 and Flame 2.2 builds.  

Actual Results:
The user cannot access Hotspot Settings while the Wi-Fi Hotspot is enabled.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150123010227
Gaia: cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Gecko: 494632b9afed
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150123002505
Gaia: 237008137f6d72b9cad25ff4faff14ff2c40ac63
Gecko: be24dd482a83
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.