Add "S-TRUST Universal Root CA" root certificate to NSS

RESOLVED FIXED

Status

NSS
CA Certificates Code
--
enhancement
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Kathleen Wilson, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: In NSS 3.18, Firefox 38)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
This bug requests inclusion in the NSS root certificate store of the following certificate, owned by Deutscher Sparkassen Verlag GmbH (DSV-Gruppe, S-TRUST).
 
Friendly Name: 	S-TRUST Universal Root CA
Cert Location: 	https://www.s-trust.de/ablage_download_dokumente/ablage_zertifikate/S-TRUST_Universal_Root_CA1.cer
SHA-1 Fingerprint: 1B:3D:11:14:EA:7A:0F:95:58:54:41:95:BF:6B:25:82:AB:40:CE:9A
Trust Flags: Email
Example Cert: https://bugzilla.mozilla.org/attachment.cgi?id=8506014

This CA has been assessed in accordance with the Mozilla project guidelines, and the certificate approved for inclusion in bug #1011182. 

The next steps are as follows:
1) A representative of the CA must confirm that all the data in this bug is correct, and that the correct certificates have been attached.
2) A Mozilla representative creates a patch with the new certificates, and provides a special test version of Firefox.
3) A representative of the CA uses the test version of Firefox to confirm (by adding a comment in this bug) that the certificates have been correctly imported and that websites work correctly.
4) The Mozilla representative requests that another Mozilla representative review the patch.
5) The Mozilla representative adds (commits) the patch to NSS, then closes this bug as RESOLVED FIXED.
6) At some time after that, various Mozilla products will move to using a version of NSS which contains the certificates. This process is mostly under the control of the release drivers for those products.
(Reporter)

Comment 1

3 years ago
Created attachment 8544306 [details]
S-TRUSTUniversalRootCA.cert
(Reporter)

Comment 2

3 years ago
Alexandru, Please see step #1 above.

Comment 3

3 years ago
I can confirm that all the data in this bug is correct.

Best regards,
Alexandru

Updated

3 years ago
Depends on: 1132496

Comment 4

3 years ago
Test builds of a development version of Firefox, which contain the requested change(s), can be found here:
https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/try-builds/kaie@kuix.de-cb8002df70cc/
(Reporter)

Comment 5

3 years ago
Alexandru, Please check the code change as described here:
https://wiki.mozilla.org/CA:How_to_apply#Testing_Inclusion
(except for step #5, since the Websites trust bit is not enable for this root)

Comment 6

3 years ago
Kathleen,

I checked the changes as described here: https://wiki.mozilla.org/CA:How_to_apply#Testing_Inclusion  (except for step 5)

I can confirm that the certificate is marked as "Builtin Object Token" in the Security Device column and the correct trust bits (E-Mail) are checked.

Best regards,
Alexandru
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: In NSS 3.18, Firefox 38
You need to log in before you can comment on or make changes to this bug.