Closed Bug 1118084 Opened 5 years ago Closed 5 years ago

Remove self-hosted and user-exposed methods from PJS

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla37

People

(Reporter: shu, Assigned: shu)

References

Details

(Keywords: dev-doc-complete, site-compat)

Attachments

(1 file)

This should be all the entry points into PJS code.
Blocks: removepjs
Attachment #8544315 - Flags: review?(lhansen)
My only concern here is that the scatter method of TypedObject array is being removed.  Given how carefully it's done I assume it's deliberate; was it introduced solely because of PJS?
Flags: needinfo?(shu)
Duplicate of this bug: 1117782
(In reply to Lars T Hansen [:lth] from comment #2)
> My only concern here is that the scatter method of TypedObject array is
> being removed.  Given how carefully it's done I assume it's deliberate; was
> it introduced solely because of PJS?

Yes, I consulted with Niko and confirmed that scatter was PJS-only, while the other array methods were not.
Flags: needinfo?(shu)
Assignee: nobody → shu
Attachment #8544315 - Flags: review?(lhansen) → review+
Note that when you land this, one test that use scatter without a correct guard will start to fail, the test needs to be rewritten or disabled:

/home/lth/moz/mozilla-inbound/js/src/jit-test/tests/ion/inlining/TypedObject-TypeDescrIsSizedArrayType.js:29:11 TypeError: v.scatter is not a function
(In reply to Lars T Hansen [:lth] from comment #5)
> Note that when you land this, one test that use scatter without a correct
> guard will start to fail, the test needs to be rewritten or disabled:
> 
> /home/lth/moz/mozilla-inbound/js/src/jit-test/tests/ion/inlining/TypedObject-
> TypeDescrIsSizedArrayType.js:29:11 TypeError: v.scatter is not a function

Yeah, this patch removes that test.
https://hg.mozilla.org/mozilla-central/rev/68d1c3fd25f1
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
You need to log in before you can comment on or make changes to this bug.