If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Hovering over a suggested URL in the address bar makes it go to that page when pressing enter, instead of what is typed in the bar

RESOLVED DUPLICATE of bug 1043584

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 1043584
3 years ago
3 years ago

People

(Reporter: Dylan, Unassigned)

Tracking

34 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

- Type an address into the address bar;
- Hover over a suggestion in the following drop-down box (NOT clicking it);
- Click the address bar once as if continueing to type (But not actually typing more);
- Press enter;


Actual results:

Firefox will now browse to the suggestion you last hovered. 


Expected results:

Firefox should have browsed to what is typed in the address bar.

Comment 1

3 years ago
Works for me on Linux with 2015-01-12-03-02-01-mozilla-central-firefox-37.0a1.ru.linux-x86_64: the dropdown disappears when I type, whether it matches an entry, or not.
QA Whiteboard: [bugday-20140112]
Component: Untriaged → Location Bar

Comment 2

3 years ago
(In reply to [:Aleksej] from comment #1)
> Works for me on Linux with
> 2015-01-12-03-02-01-mozilla-central-firefox-37.0a1.ru.linux-x86_64: the
> dropdown disappears when I type, whether it matches an entry, or not.

I misread the description, but the dropdown also disappears when I click the address.

Updated

3 years ago
QA Whiteboard: [bugday-20140112] → [bugday-20150112]
(Reporter)

Comment 3

3 years ago
(In reply to [:Aleksej] from comment #2)
> (In reply to [:Aleksej] from comment #1)
> > Works for me on Linux with
> > 2015-01-12-03-02-01-mozilla-central-firefox-37.0a1.ru.linux-x86_64: the
> > dropdown disappears when I type, whether it matches an entry, or not.
> 
> I misread the description, but the dropdown also disappears when I click the
> address.

The bug is not that the dropdown box doesn't disappear. I don't know how you thought that from my description and I don't know how to make the description clearer than it is. 

The bug is that Firefox browses to the page you just hover selected with your mouse when pressing enter, even when the address bar has something else typed in it.

So you type "hotmail.com", in the dropdown suggestion sites you run your mouse over a YouTube page with "hotmail.com" in it, you don't click the suggestion but you click the address bar (making the dropdown box disappear) and you press enter.
Firefox now browses to the YouTube page and NOT hotmail.com.

I would make a video if I knew how.

Comment 4

3 years ago
What I did was type "mozi", in the dropdown suggestion I hovered over a http…://mozilla.org/… address, then clicked the address bar, pressed Enter, and Firefox opened a Yandex search for "mozilla" derived from "mozi".
(Reporter)

Comment 5

3 years ago
(In reply to [:Aleksej] from comment #4)
> What I did was type "mozi", in the dropdown suggestion I hovered over a
> http…://mozilla.org/… address, then clicked the address bar, pressed Enter,
> and Firefox opened a Yandex search for "mozilla" derived from "mozi".

Those are indeed the steps I take that causes my problem! A third person's attempt would benefit.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043584
You need to log in before you can comment on or make changes to this bug.