[Flame][Video]Record a video, the video preview displays as black.

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: yue.xia, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted file logcat
[1.Description]:
[Flame v2.2][Video]Launch Camera and record a video, the video preview is displayed as black on View Finder screen and Gallery view.
See attachment: logcat_0417.txt & Video1.MP4
Found time: 04:17

[2.Testing Steps]: 
1. Launch Camera.
2. Record a video.
3. Stop recording video.
4. Launch Gallery.

[3.Expected Result]: 
3. The recorded video preview is not displayed as black on View Finder screen.
4. The video preview is not displayed as black in Gallery.

[4.Actual Result]: 
3. The preview of recorded video is displayed as black on View Finder screen.
4. The video preview is displayed as black in Gallery.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/55f3224d7513
Build-ID        20150104010206
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free test
(Reporter)

Comment 1

4 years ago
Posted video Video
blocking-b2g: --- → 2.2?
Keywords: regression

Comment 2

4 years ago
I don't think there are any changes going into the app side in 2.2/master that causes this issue. Russ please do the initial investigation. If it is not the app issue, lets move it Audio/Video component to get the right set of folks looking into this.

Blocking Reason: Broken basic functionality
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(rnicoletti)
I don't see any change to the gallery app code that generates the poster image for videos since as far back as 1.4. However, I could not reproduce the problem with 1.4 and 2.0 (build ID 20141016183911). I can reproduce with 2.2 (build ID 20150105010205).

Requesting regression window.
Flags: needinfo?(rnicoletti)
Keywords: qawanted
QA Contact: bzumwalt
In latest Flame 2.2 build this issue does not reproduce. Both video preview thumbnail and image in camera appear correctly, as well as video thumbnails in gallery app. It is possible that bug 1101230 fixed this issue as the prior testing for this issue was conducted on builds created before the commit.

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20150108010221
Gaia: d4dac29613076bdba3cb8adc217deadb08a2ac20
Gecko: 70de2960aa87
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 5

4 years ago
Marking this as worksforme based on previous comment 4. If the problem is reproducible please reopen.

Thanks
Hema
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
The newly created video is showing proper thumbnail on my v2.2 flame, but old video clips(also recorded from flame with master a week ago, before branch) are still showing black.

Hi Shine, Could you try to check if this is a factor, also the location of storage(Settings -> Media Storage-> Default Media Location), open a new bug or reopen this if needed.
Thank you.
Flags: needinfo?(yue.xia)
(Reporter)

Comment 7

4 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #6)
> The newly created video is showing proper thumbnail on my v2.2 flame, but
> old video clips(also recorded from flame with master a week ago, before
> branch) are still showing black.
Hi Eric,
As you said, in Gallery app, the old video clips are still showing black. Do we need to reopen this bug?

> Hi Shine, Could you try to check if this is a factor, also the location of
> storage(Settings -> Media Storage-> Default Media Location), open a new bug
> or reopen this if needed.
When set the "Default Media Location" to “SD card” and “Internal”, this problem can't be repro on latest build of Flame2.2.

Flame 2.2 build:
Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150118.035516
FW-Date         Sun Jan 18 03:55:27 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(yue.xia) → needinfo?(echang)
We can clone this, but just want to clarify first, new video are fine, old video are black, and after setting "Default Media Location" to either "SD" or "Internal", we cannot reproduce this issue? Is my understanding correct? 

(In reply to Shine from comment #7)
> > Hi Shine, Could you try to check if this is a factor, also the location of
> > storage(Settings -> Media Storage-> Default Media Location), open a new bug
> > or reopen this if needed.
> When set the "Default Media Location" to “SD card” and “Internal”, this
> problem can't be repro on latest build of Flame2.2.
> 
> Flame 2.2 build:
> Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
> Gecko-Rev      
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
> Build-ID        20150118002501
> Version         37.0a2
> Device-Name     flame
> FW-Release      4.4.2
> FW-Incremental  eng.cltbld.20150118.035516
> FW-Date         Sun Jan 18 03:55:27 EST 2015
> Bootloader      L1TC000118D0
Flags: needinfo?(echang) → needinfo?(yue.xia)
(Reporter)

Comment 9

4 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #8)
> new video are fine, old video are black, and after setting "Default Media Location" to either "SD"
> or "Internal", we cannot reproduce this issue.

Hi Eric,
Your understanding is right.
Flags: needinfo?(yue.xia)
Looks like the files themselves have something weird that makes this happen, not the app. I can reproduce that only with those 2 videos(which are taken by flame-kk master 0106)
You need to log in before you can comment on or make changes to this bug.