Closed Bug 1118391 Opened 5 years ago Closed 5 years ago

[RTL][Settings] Dialogs are left-aligned.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S5 (6feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: ychung, Assigned: gasolin)

References

Details

Attachments

(3 files)

Attached image DialogLeftAligned.png
Description:
The text on dialog is left-aligned when the user enables Data Connection or Data roaming under Cellular & Data. This issue also occurs when the user tries to reset the device under Developer.

Repro Steps:
1) Update a Flame device to BuildID: 20150106010234.
2) Set the device language in Arabic under Settings > Language.
3) Go to Settings > Cellular & Data > Data Connection or Data Roaming, or Settings > Developer > Reset and root the phone.
4) Observe the dialog message.
  
Actual:
Text in dialog is left-aligned.
  
Expected: 
Text in dialog is right-aligned.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150106010234
Gaia: b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko: 2a193b7f395c
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Decided during triage this morning to block on this
blocking-b2g: --- → 2.2?
Priority: -- → P1
Blocking per RTL triage for 2.2
blocking-b2g: 2.2? → 2.2+
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
blocking-b2g: 2.2+ → ---
feature-b2g: --- → 2.2+
Assignee: nobody → gasolin
Comment on attachment 8555692 [details] [review]
[PullReq] gasolin:issue-1118391 to mozilla-b2g:master

test on device shows text normally on en and align right on arabic.
Attachment #8555692 - Flags: review?(ejchen)
Comment on attachment 8555692 [details] [review]
[PullReq] gasolin:issue-1118391 to mozilla-b2g:master

Thanks Fred, this patch looks nice to me !!

r+
Attachment #8555692 - Flags: review?(ejchen) → review+
merged https://github.com/mozilla-b2g/gaia/commit/7b4c3c5ed874fa62ff92761c36af078330daa1c8

thanks!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8555692 [details] [review]
[PullReq] gasolin:issue-1118391 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): feature 2.2
[User impact] if declined: dialog not align right
[Testing completed]: treeherder passed
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8555692 - Flags: approval-gaia-v2.2?
Attachment #8555692 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue has been verified successufully on Flame 2.2/3.0.
Reproduce rate:0/5.
Attachment:Verify_RTL_Dailog.png

Flame 2.2 build:

Gaia-Rev        d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f7414413e3a5
Build-ID        20150201002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150201.043120
FW-Date         Sun Feb  1 04:31:31 EST 2015
Bootloader      L1TC000118D0

Flame 3.0 build:

Gaia-Rev        ab69ae06a7f2b54e60ab63b1b44c8d19d5d20d94
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/c2359a6a6958
Build-ID        20150201010217
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150201.044915
FW-Date         Sun Feb  1 04:49:25 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
Attached image Verify_RTL_Dialog.png
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15781/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.