Enabling hardware vsync and the vsync aligned compositor on b2g is failing mochitests

RESOLVED WORKSFORME

Status

()

Core
Widget: Gonk
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: mchang, Assigned: mchang)

Tracking

26 Branch
x86
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

3 years ago
From https://treeherder.mozilla.org/#/jobs?repo=try&revision=7aec6db39716 - Lots of mochitests are failing on b2g if we enable silk and the compositor on by default. Find and fix the issues that are causing the tests to fail.
(Assignee)

Comment 1

3 years ago
Looking a lot better with the updated version of the software vsync thread - https://treeherder.mozilla.org/#/jobs?repo=try&revision=d9d7fd0b2a60
(Assignee)

Updated

3 years ago
Blocks: 1119981
(Assignee)

Comment 2

3 years ago
Looking good with the correct fallback to software vsync - https://treeherder.mozilla.org/#/jobs?repo=try&revision=6e17ae57b910
(Assignee)

Updated

3 years ago
Depends on: 1122943
(Assignee)

Comment 3

3 years ago
After disabling vsync when idle (bug 1095242) and ensuring compositor vsync observers shut down correctly (bug 1122943), try looking good with vsync compositor enabled. 

https://treeherder.mozilla.org/#/jobs?repo=try&revision=01c59c967973
(Assignee)

Comment 4

3 years ago
After bug 1122943, tree is green. Nothing actionable left on this bug, but will leave it open until after the silk compositor lands.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=3685c1ebed05 (Note, Windows 7 Debug mochitest-browser-chrome 1 is failing on disabled test https://bugzilla.mozilla.org/show_bug.cgi?id=1113038#c354).
(Assignee)

Comment 5

3 years ago
Since the compositor has landed and has been passing for a few days, resolving this bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.