Closed Bug 1118728 Opened 6 years ago Closed 6 years ago

Update Phone app object to wait for the app to launch

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Bebe, Assigned: Bebe)

Details

Attachments

(1 file)

Some tests are failing because the Phone app takes a little longer to launch.


Update the app object to wait for the app to launch
QA Whiteboard: [fxosqa-auto-s7]
Comment on attachment 8545232 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27197

Looks good to me. I started http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/551 to make sure of the fix on the redial test.
Attachment #8545232 - Flags: review?(jlorenzo) → review+
Comment on attachment 8545232 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27197

I started another adhoc, as the previous one failed(device not found): http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/555/console
Adhoc looks good, r+
Attachment #8545232 - Flags: review?(viorela.ioia) → review+
(In reply to Viorela Ioia [:viorela] from comment #5)
> Comment on attachment 8545232 [details] [review]
> Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27197
> 
> I started another adhoc, as the previous one failed(device not found):
> http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc/555/console
> Adhoc looks good, r+

Adhoc looks good, 2 failures unrelated :)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.