Last Comment Bug 111874 - Display new tab URL, old URLs consistently
: Display new tab URL, old URLs consistently
Status: VERIFIED DUPLICATE of bug 104778
:
Product: SeaMonkey
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: x86 Windows 98
: -- normal (vote)
: Future
Assigned To: jag (Peter Annema)
: sairuh (rarely reading bugmail)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-25 12:48 PST by xyzzy
Modified: 2008-07-31 01:19 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description xyzzy 2001-11-25 12:48:11 PST
Build 2001112003 Windows 98

1) Use Ctrl+T to open a new tab.
2) Select a different tab.
3) Select original tab.

Actual results:

First step shows URL bar with empty text field.  In the third step it is now
called about:blank.

Expected results:

The same display name should be used in either case.  Either Ctrl+T should pull
up a window with about:blank as text, or step 3 should give an empty field.

Alternately, Ctrl+T could bring up about:blank and make it selected, so that any
typing would overwrite it, allowing consistent naming and easy typing into the
new tab URL bar.
Comment 1 Chris Brien 2001-11-25 13:31:10 PST
The summary isn't very descriptive, but...

This is an artifact caused by bug 103720. about:blank is being loaded, but
doesn't show. The difference is that about:blank doesn't generate the event that
would fill the URL bar with the correct URL on loading. This isn't quite a
duplicate, but would be fixed when bug 103720 is fixed.
Comment 2 Joe Hewitt (gone) 2001-12-02 22:56:33 PST
-> tabbed browser
Comment 3 David Hyatt 2002-01-21 13:53:20 PST
Reassigning to new component owner.
Comment 4 jag (Peter Annema) 2002-01-21 22:57:12 PST
-> future, helpwanted
Comment 5 Hixie (not reading bugmail) 2002-04-14 12:18:38 PDT

*** This bug has been marked as a duplicate of 104778 ***
Comment 6 sairuh (rarely reading bugmail) 2002-08-20 22:16:32 PDT
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica

Note You need to log in before you can comment on or make changes to this bug.