[Metrics] AppUsage collection shall be for Apps from Marketplace

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Ravi Dandu, Assigned: marshall_law)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
AppUsage metric collection shall be restricted to following:
1) Apps from Firefox OS Marketplace, and
2) Preinstalled Apps
App installed from other marketplace's and locally should not be part of the metric collected by Mozilla. 

This will help other marketplace users have choices of privacy.

This requirement enhances the original Bug 1109422 - AppUsage Metric collection enhancements for MonthlyActiveUsers computation.
(Reporter)

Updated

3 years ago
Assignee: nobody → marshall
(Reporter)

Comment 1

3 years ago
The following is proposed for identification of such apps:                                             
1) Firefox OS marketplace: Tracking the "install origin" inside the app database, 'Mozilla marketplace",  

2) Preinstalled: Preinstalled apps will either have an "install origin" of the mozilla marketplace, or their app-type will be "certified".

Comment 2

3 years ago
Marshall, please add an ETA to this bug!

Ravi, If this is a blocker for 2.2, please add blocker justification and work with release owner to get this approved.

Thanks
Hema
Flags: needinfo?(rdandu)
Flags: needinfo?(marshall)
Target Milestone: --- → 2.2 S5 (6feb)
(Reporter)

Comment 3

3 years ago
Kevin, 
    Please include this in 2.2. This bug is finetuning the main metric bug 1109422 for Appusage which is method to derive MAU (Monthly Active Users). MAU is the critical metric to track FxOS, decided upon across the products. 

This bug excludes Apps outside of Firefox OS Marketplace.
1)This is to ensure privacy in certain cases. eg: if LGBT community in Russia is hosting app marketplace, we do not want have any info on those apps to ensure additional privacy. 
2)For apps from Firefox OS Marketplace, we already know that they have been installed. Hence they are to be included in the metrics.
blocking-b2g: --- → 2.2?
Flags: needinfo?(rdandu) → needinfo?(khu)

Comment 4

3 years ago
Created attachment 8560724 [details] [review]
[PullReq] marshall:bug1119009_marketplaceApps to mozilla-b2g:master
(Assignee)

Updated

3 years ago
Flags: needinfo?(marshall)
Attachment #8560724 - Flags: review?(dflanagan)

Updated

3 years ago
Flags: in-moztrap?(slyu)

Updated

3 years ago
Depends on: 1131315

Updated

3 years ago
No longer depends on: 1131315

Updated

3 years ago
Blocks: 1131315
Comment on attachment 8560724 [details] [review]
[PullReq] marshall:bug1119009_marketplaceApps to mozilla-b2g:master

r+ for the code changes, but think about:

1) allowing more than one marketplace url, so that partners don't replace our url with their url. Give them a way to add their url.

2) are you sure that testing for type===certified is the right way to detect a pre-installed app?  A lot of developers want to reduce the privilege of the preinstalled apps.  Maybe checking for gaiamobile.org instead?
Attachment #8560724 - Flags: review?(dflanagan) → review+
I agree with David on point 2. Also, since we moved to opt-out now, you might get a lot of data from engineering build that has certified testing apps.

(In reply to David Flanagan [:djf] from comment #5)
> Comment on attachment 8560724 [details] [review]
> [PullReq] marshall:bug1119009_marketplaceApps to mozilla-b2g:master
> 
> r+ for the code changes, but think about:
> 
> 1) allowing more than one marketplace url, so that partners don't replace
> our url with their url. Give them a way to add their url.
> 
> 2) are you sure that testing for type===certified is the right way to detect
> a pre-installed app?  A lot of developers want to reduce the privilege of
> the preinstalled apps.  Maybe checking for gaiamobile.org instead?

Comment 7

3 years ago
Triage is blocking based on the fact that Metrics is a key initiative and high priority.
blocking-b2g: 2.2? → 2.2+

Updated

3 years ago
Target Milestone: 2.2 S5 (6feb) → 2.2 S6 (20feb)
(Assignee)

Comment 8

3 years ago
I've made the MARKETPLACE_ORIGINS an array to allow partners to add other sources if they need, and I've also added a check for 'gaiamobile.org' in the manifestURL as another case that signifies a preinstalled app
(Assignee)

Comment 9

3 years ago
master - https://github.com/mozilla-b2g/gaia/commit/56c9e554bf39ad05e61fd83b33dffabb1957dcfa
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 10

3 years ago
Created attachment 8567371 [details] [review]
[gaia] marshall:bug1119009_marketplaceApps_v2.2 > mozilla-b2g:v2.2
(Assignee)

Comment 11

3 years ago
Comment on attachment 8567371 [details] [review]
[gaia] marshall:bug1119009_marketplaceApps_v2.2 > mozilla-b2g:v2.2

Only report apps preinstalled apps or installed from marketplace in AppUsageMetrics

[Bug caused by] (feature/regressing bug #): Bug 1119009
[User impact] if declined: We will collect app usage for sideloaded / testing apps

[Testing completed]: Unit and manual
[Risk to taking this patch] (and alternatives if risky): This may filter out some apps we want unintentionally

[String changes made]: None
Attachment #8567371 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

3 years ago
Attachment #8567371 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/82e3bdc393ac6d8ec920d29b8dc4bc0f51b5fff3
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed

Updated

3 years ago
Depends on: 1137063

Comment 13

3 years ago
clear ni because it's in 2.2.
Flags: needinfo?(khu)
Created attachment 8583618 [details]
MozTrap Cases

Updated

3 years ago
Flags: in-moztrap?(slyu) → in-moztrap+
You need to log in before you can comment on or make changes to this bug.