hangs if more than 77 "Confirm setting cookie" windows are open

RESOLVED WONTFIX

Status

()

--
critical
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: ftomi2, Unassigned)

Tracking

({hang, testcase})

34 Branch
hang, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8545854 [details]
cookie.html - for reproducing the bug

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141127111021

Steps to reproduce:

I created a test page to examine the behaviour of popsci.com articles. They store the scroll position in a cookie. 
So visit http://users.itk.ppke.hu/~fenta/vajon/cookie.html
Scroll up and down, and watch the counter. 


Actual results:

After 77 scroll events (bound to set cookie), no more "Confirm setting cookie" window opens. After about 130-140 scroll events, all firefox windows disappear, but the process is running. If I run it from console, it doesn't let me know what had happened.


Expected results:

I expected that firefox will handle infinite "Confirm setting cookie" windows or at least infinite set cookie events. I think this would be fair for people caring cookies, since websites tend to use more and more cookies.
(Reporter)

Comment 1

4 years ago
I set the following in Preferences:
Privacy -> History: Use custom settings for history -> Accept cookies from sites: yes -> Keep until: Ask me every time
(This setting is good for web developers)

Comment 2

4 years ago
See also https://bugzilla.mozilla.org/show_bug.cgi?id=748620#c6 .
Blocks: 469260
Component: Untriaged → Bookmarks & History

Updated

4 years ago
Severity: normal → critical
Keywords: hang, testcase
Summary: crash if more than 77 "Confirm setting cookie" windows are open → hangs if more than 77 "Confirm setting cookie" windows are open

Updated

4 years ago
Component: Bookmarks & History → General
Didn't we remove the "Confirm setting cookie" feature?
Severity: critical → normal

Comment 4

3 years ago
(In reply to Mats Palmgren (:mats) from comment #3)
> Didn't we remove the "Confirm setting cookie" feature?

bug 606655.
No longer blocks: 469260
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Depends on: 606655
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.