Closed Bug 1119219 Opened 6 years ago Closed 5 years ago

[Windows/Linux] Bookmark widget label is not aligned correctly in palette

Categories

(Firefox :: Theme, defect)

defect
Not set
normal
Points:
3

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Gijs, Unassigned, Mentored)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P4-] [diamond] [qx:link:spec] [lang=css])

+++ This bug was initially created as a clone of Bug #986970 +++

When the bookmark widget is in the palette its label is not vertically aligned with the other labels. See the screenshot. Reproduced on Windows 7 with the latest Nightly.


The OS X version of this issue was fixed in bug 986970. The Windows/Linux fix can probably look similar, but not quite the same... in particular, at least on Windows, it looks like while all the other buttons have a transparent border, the bookmarks widget does not, while the browser toolbox finds no CSS that is actually doing the disabling of the border - it's all a bit fishy. Maybe using DOM Inspector ( https://addons.mozilla.org/addon/dom-inspector-6622/ ) will be mor euse here.
(In reply to Gijs Kruitbosch from comment #0)
> See the screenshot.

This would be attachment 8395459 [details].
Component: Toolbars and Customization → Theme
For Linux, we should be the new rule near https://dxr.mozilla.org/mozilla-central/source/browser/themes/linux/customizableui/panelUIOverlay.css#101
For Windows, we should be adding the new rule near https://dxr.mozilla.org/mozilla-central/source/browser/themes/windows/customizableui/panelUIOverlay.css#124
Whiteboard: [Australis:P4-] [diamond] [qx] → [Australis:P4-] [diamond] [qx] [lang=css]
Hey Blake
Can I work on this bug?
(In reply to Vaibhav Bhosale from comment #3)
> Hey Blake
> Can I work on this bug?

Sure. It seems like the links here:

(In reply to Blake Winton (:bwinton) from comment #2)
> For Linux, we should be the new rule near
> https://dxr.mozilla.org/mozilla-central/source/browser/themes/linux/
> customizableui/panelUIOverlay.css#101
> For Windows, we should be adding the new rule near
> https://dxr.mozilla.org/mozilla-central/source/browser/themes/windows/
> customizableui/panelUIOverlay.css#124

are outdated, though... Blake, can you be more explicit about what you have in mind, also in terms of the new rule that needs to be added?
Flags: needinfo?(bwinton)
Gijs, I believe those are the correct places in those files to add the new rule.

I suspect the new rule will be very similar to the one added for Mac, which is:
  toolbarpaletteitem[place="palette"] > .toolbarbutton-1 > .toolbarbutton-menubutton-button {
    padding: 3px 1px;
  }
but I don't know for certain.  Some investigation and playing around with CSS values will be needed, I suspect.

Vaibhav, based on your comments in other bugs, it looks like you're able to build Firefox.  Is that correct?  If so, I think the next step would be to add the rule above to the Windows or Linux css file, build it, and see how it looks.  Does that sound reasonable to you?
Flags: needinfo?(bwinton)
Hey Blake,
Can you help me in locating where I can find the `Additional Tools and Features` option in the browser?
Certainly!  Just click the Menu Button, then "Customize", and it's the large section on the left.  :)
This seems to be working right now. Closing.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [Australis:P4-] [diamond] [qx] [lang=css] → [Australis:P4-] [diamond] [qx:link:spec] [lang=css]
You need to log in before you can comment on or make changes to this bug.