[Smart Collection] Remove option for custom smart collection

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: WDM, Assigned: kgrandon)

Tracking

unspecified
2.2 S4 (23jan)
Other
Other
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Right now if users add a custom Smart Collection by long pressing on the homescreen they can create a collection via a custom search.  

Since search will stop functioning (at least usefully), we should remove that ability in 2.2.  

We should not have a custom option for the user to select.
(Reporter)

Updated

3 years ago
Flags: needinfo?(kgrandon)
feature-b2g: --- → 2.2+
Whiteboard: [systemsfe]
(Assignee)

Updated

3 years ago
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Flags: needinfo?(kgrandon)
(Assignee)

Comment 1

3 years ago
Wilfred - Can you provide a spec or string to use when there are no more smart collections available to be added? Currently each time you add a smart collection to the home screen, it gets removed from the list. Eventually you are only left with a single option today, and that is the 'Custom' option. I suppose in this case we should just show a message to the user and return to the home screen.
Flags: needinfo?(wmathanaraj)
Created attachment 8546221 [details] [review]
[PullReq] KevinGrandon:bug_1119226_remove_custom_collection_create to mozilla-b2g:master
(Reporter)

Comment 3

3 years ago
so here is my thought on it that i mentioned to francis in UX as well:

We display currently on long press the "add smart collection" item. If the user has "used" up all options then we should not display the "add smart collection" option on the long press menu.

If the user at some point deletes one of his added smart collections then we can display the menu again.

This way we save on creating a new string, and menu is only there when needed. 

I will NI Katie and Francis to comment if this is a good way yot handle it.
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(kcaldwell)
Flags: needinfo?(fdjabri)
(Assignee)

Comment 4

3 years ago
Unfortunately the home screen does not really have knowledge of the available smart collections. I think we're going to need to come up with *some* message here. E.g., "You have added all available smart collections."

I don't think we have time in 2.2 to do anything nicer than that.
I'm not sure what our exact copy guidelines are for empty states, but it seems we're generally less chatty in these cases. i.e., in Contacts we say "No contacts". So my 2c would be to change this to something like: "No smart collections left to add". Leaving this to Katie for the final call as she's the UX owner for Home screen.
Flags: needinfo?(fdjabri)

Comment 6

3 years ago
My ux preference is the same as Wilfred's recommendation in comment 3 (remove the option), but as Kevin says in Comment 4, the system can't tell if all the smart collections have been added. With that, I'll assume that that also means we can't change the button language from "Add Smart Collections" to simply "Smart Collections", so... my recommendation is, "All smart collections have been added."
Flags: needinfo?(kcaldwell)
Target Milestone: --- → 2.2 S5 (6feb)
(Assignee)

Comment 7

3 years ago
Comment on attachment 8546221 [details] [review]
[PullReq] KevinGrandon:bug_1119226_remove_custom_collection_create to mozilla-b2g:master

Chris or Dale - could one of you take a look and review this code? It's mostly just deleting things. Thanks!
Attachment #8546221 - Flags: review?(dale)
Attachment #8546221 - Flags: review?(chrislord.net)

Comment 8

3 years ago
Comment on attachment 8546221 [details] [review]
[PullReq] KevinGrandon:bug_1119226_remove_custom_collection_create to mozilla-b2g:master

Looks good to me.
Attachment #8546221 - Flags: review?(dale)
Attachment #8546221 - Flags: review?(chrislord.net)
Attachment #8546221 - Flags: review+
(Assignee)

Comment 9

3 years ago
In master: https://github.com/mozilla-b2g/gaia/commit/cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

3 years ago
Comment on attachment 8546221 [details] [review]
[PullReq] KevinGrandon:bug_1119226_remove_custom_collection_create to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New "feature" - we are removing custom collections as they will stop functioning in the future.
[User impact] if declined: Poor experience when adding custom collections.
[Testing completed]: Manual and a unit test.
[Risk to taking this patch] (and alternatives if risky): Low risk, just deletes code.
[String changes made]: Yes.
Attachment #8546221 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

3 years ago
Attachment #8546221 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/ca4ee12a3689d6ff4a1ef529cc15e5628b6bc232
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: 2.2 S5 (6feb) → 2.2 S4 (23jan)
This issue is verified fixed on Flame Master.

Result: The custom smart collection option does not exist.
 
Device: Flame Master (319mb, full flash)
BuildID: 20150123010227
Gaia: cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Gecko: 494632b9afed
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

=================================================
Leaving verifyme for Flame 2.2.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(ychung)
This issue is verified fixed on Flame 2.2.

Result: The custom smart collection option does not exist.

Device: Flame 2.2 (319mb, full flash)
Build ID: 20150126002536
Gaia: 0518f4581a0925c0b703d730ef289ab15cbd1216
Gecko: c6aa604a7967
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ychung) → needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Test cases in MozTrap: https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-tag=3104
Flags: in-moztrap+
Test run to sign off v2.2 Feature Landing

***Test Summary***
2 test cases ran, 2 passed

***Test Run record***
https://moztrap.mozilla.org/results/cases/?&pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-tag=3104&filter-run=6441

***Build Info***
Build ID               20150215002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.040754
Firmware Date          Sun Feb 15 04:08:04 EST 2015
Bootloader             L1TC000118D0
You need to log in before you can comment on or make changes to this bug.