Closed Bug 1119278 Opened 5 years ago Closed 5 years ago

Intermittent test_music_change_rating.py TestSetMusicRating.test_music_change_rating | ValueError: time data u'' does not match format '%M:%S'

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S4 (23jan)
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: cbook, Assigned: RobertC)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

b2g_macosx64 mozilla-central opt test gaia-ui-test-functional-2

https://treeherder.mozilla.org/logviewer.html#?job_id=852790&repo=mozilla-central

02:19:40 ERROR - TEST-UNEXPECTED-ERROR | test_music_change_rating.py TestSetMusicRating.test_music_change_rating | ValueError: time data u'' does not match format '%M:%S'
Assignee: nobody → robert.chira
QA Whiteboard: [fxosqa-auto-s7+]
I was not able to reproduce the issue locally, so this is a blind attempt at fixing the bug.
Attachment #8546662 - Flags: review?(jlorenzo)
Attachment #8546662 - Flags: review?(florin.strugariu)
Comment on attachment 8546662 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27280

Looks good to me at first. I triggered more retries[1] on f1 under Linux and f3 under Mac OS with your PR to see if we see the intermittent again.

I'll r+ if the tests pass there.

[1] https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=a9417851474d
Comment on attachment 8546662 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27280

The test failed 2/79 times on MacOS. The fix doesn't seem like the right one.
Attachment #8546662 - Flags: review?(jlorenzo)
Comment on attachment 8546662 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27280

I updated the PR.
Attachment #8546662 - Flags: review?(jlorenzo)
Attachment #8546662 - Flags: review?(florin.strugariu) → review+
QA Whiteboard: [fxosqa-auto-s7+] → [fxosqa-auto-from-s7] [fxosqa-auto-s8]
Comment on attachment 8546662 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27280

104 execution on Gaia Try. Only 2 failures, which are unrelated. Looks like this intermittent is fixed \o/

[1] https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=7d4fb4fb0549
Attachment #8546662 - Flags: review?(jlorenzo) → review+
Gaia is closed for now, I can't merge your PR. NI myself to remember to do the merge.
Flags: needinfo?(jlorenzo)
Merged in master at: https://github.com/mozilla-b2g/gaia/commit/3d1d81bc3e731a58fb1f7b75bb8443f1c62a5ee2
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jlorenzo)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.