[RTL][Search] Close button is overlapping the x icon in the search bar

VERIFIED DUPLICATE of bug 1121748

Status

Firefox OS
Gaia::Search
P1
normal
VERIFIED DUPLICATE of bug 1121748
3 years ago
2 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

Description:
The "Close" button is overlapping the "x" icon in the search bar.

Repro Steps:
1) Update a Flame device to BuildID: 20150108010221.
2) Set the device language in Arabic under Settings > Language.
3) Tap on the "Rocketbar" on the home screen and type in some text.
4) Observe the "Close" button and the "x" icon.

Actual:
The "Close" button is overlapping the "x" icon.
  
Expected: 
No overlapping occurs.

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150108010221
Gaia: d4dac29613076bdba3cb8adc217deadb08a2ac20
Gecko: 70de2960aa87
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100% 5/5
See attached: screenshot
Created attachment 8546209 [details]
CloseButtonOverlap.jpg
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
Decided during triage this morning that this would in fact block 2.2
blocking-b2g: --- → 2.2?
Priority: -- → P1
Blocking per RTL triage for 2.2
blocking-b2g: 2.2? → 2.2+
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
blocking-b2g: 2.2+ → ---
feature-b2g: --- → 2.2+
Whiteboard: [systemsfe]
qawanted to see if this is still an issue.
Keywords: qawanted
I think this is resolved now, please verify. There was another bug which did RTL for search/rocketbar, but I can't remember the bug number right now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
This issue is only fixed on 2.2, it still occurs on 3.0 builds. (When the issue was reported 2.2 was central, but is not anymore.)

Issue is FIXED

Environmental Variables:
Device: Flame 2.2
BuildID: 20150202002507
Gaia: d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko: be206fa2fb60
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Issue is NOT fixed

Environmental Variables:
Device: Flame 3.0
BuildID: 20150202154235
Gaia: 4171327fce4803c52b2fae8071b114a70a3a68a7
Gecko: 3bf7ed413e87
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → REOPENED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
status-b2g-v2.2: affected → fixed
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: qawanted
Resolution: WORKSFORME → ---
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)

Comment 8

3 years ago
This issue has been verified successfully on Flame 2.2.
Reproduce rate:0/5.
Attachment: Verify_RTL_Closebutton.png.

Flame2.2 build:

Gaia-Rev        d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/be206fa2fb60
Build-ID        20150202002507
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150202.035604
FW-Date         Mon Feb  2 03:56:15 EST 2015
Bootloader      L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
status-b2g-v2.2: fixed → verified

Comment 9

3 years ago
Created attachment 8558273 [details]
Verify_RTL_Closebutton.png
(In reply to Kevin Grandon :kgrandon from comment #6)
> I think this is resolved now, please verify. There was another bug which did
> RTL for search/rocketbar, but I can't remember the bug number right now.

Kevin, any ideas on why this might be fixed in 2.2 and not on master?
Flags: needinfo?(kgrandon)
(In reply to Michael Henretty [:mhenretty] from comment #10)
> Kevin, any ideas on why this might be fixed in 2.2 and not on master?

If I was a betting man, I'd say that bug 1121748 is causing weirdness here too.
Depends on: 1121748
Let's see what happens with bug 1121748. If it still exists after that's fixed I'll take a look. Not sure what's going on off the top of my head unfortunately.
Flags: needinfo?(kgrandon)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15445/
Flags: in-moztrap+

Comment 14

3 years ago
Dear Candice,
Can you help to find someone help on this bug?
Thanks!
Status: REOPENED → NEW
Flags: needinfo?(cserran)
ni'ing Michael for update and assignment
Flags: needinfo?(cserran) → needinfo?(mhenretty)
Marking as dupe of bug 1121748. Let's get this verified on master.
Status: NEW → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(mhenretty)
Keywords: verifyme
Resolution: --- → DUPLICATE
Duplicate of bug: 1121748

Comment 17

3 years ago
This issue has been make as verified for flame 3.0 on bug 1121748,
So clear the keywords
Keywords: verifyme
Target Milestone: --- → 2.2 S5 (6feb)
Created attachment 8640341 [details]
Verify2_master.png

Bug 1121748 has been verified as pass, and this issue is verified as pass on latest Flame&N5 master build by the same STR in comment 0, close button does not overlap with the x icon in the search bar.

See attachment:Verify2_master.png.
Reproducing rate: 0/10

Flame master build (Pass):
Build ID               20150728030208
Gaia Revision          14e32276025b0310d3e89027320cf4b2a24cedfb
Gaia Date              2015-07-27 16:43:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/33dc8a83cfc0
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150728.064331
Firmware Date          Tue Jul 28 06:43:41 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

N5 master build (Pass):
Build ID               20150728150207
Gaia Revision          862f0895f3f5a97200601542d99a152a46385a0b
Gaia Date              2015-07-28 15:30:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/833403badc41
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150728.182857
Firmware Date          Tue Jul 28 18:29:15 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.