inner table is not cented when <TD> CSS text-align: center

VERIFIED DUPLICATE of bug 49274

Status

()

Core
Layout: Tables
VERIFIED DUPLICATE of bug 49274
16 years ago
16 years ago

People

(Reporter: Saulius Gurklys, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+)
Gecko/20011125
BuildID:    2001112508

Table's <TD> has CSS class which text-align defines as center
When <TD> contens is other table, table is not centered while
text contens is centered

Reproducible: Always
Steps to Reproduce:
1.launch mozilla
2.open URL http://www.vtex.lt/sagu/tat.html
3.

Actual Results:  inner table is left aligned(not centered)

Expected Results:  inner table MUST be centered

test file:
<html>
<head>
<style type="text/css">
.ca {text-align: center;}
</style>
</head>
<body>
<table width="30%" border=1>
<tr><td class="ca"><table border=1><tr><td>inner table is not centered</table>
<tr><td class="ca">while text is centered
</table>
</body>
</html>
(Reporter)

Comment 1

16 years ago
Created attachment 59165 [details]
simple test

Comment 2

16 years ago
text-align isn't meant to center tables, so you have wrong expectations ;)
DUP of (INVALID) bug #49274.
Indeed.  text-align does not, should not, and will not center blocks, which is
what tables are.  Use "margin-left: auto; margin-right: auto" on the table. 
(bug 49274 has the details).

*** This bug has been marked as a duplicate of 49274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
 verified that this is a dupe of Bug # 49274 and its invalid
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.