Placeholder opacity of number input cannot change

RESOLVED DUPLICATE of bug 1004130

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1004130
3 years ago
3 years ago

People

(Reporter: eddie.moore, Unassigned)

Tracking

({css-moz, css2, css3})

34 Branch
x86
Mac OS X
css-moz, css2, css3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36

Steps to reproduce:

//CSS
:-moz-placeholder { /* Firefox 18- */
   color: $white;
   opacity: 1;
}

::-moz-placeholder {  /* Firefox 19+ */
   color: $white;
   opacity: 1;
}


//HTML
<input type="number" placeholder="D">


Actual results:

Opacity of placeholder stays at default value.


Expected results:

Opacity of placeholder of "number" input should change fully opaque.
It works with type="text" but not with type="number"
(Reporter)

Updated

3 years ago
Keywords: css-moz, css2, css3
(Reporter)

Comment 1

3 years ago
Sorry I copied the css from Scss. Change color to an actual colour.

//CSS
:-moz-placeholder { /* Firefox 18- */
   color: white;
   opacity: 1;
}

::-moz-placeholder {  /* Firefox 19+ */
   color: white;
   opacity: 1;
}
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1004130
You need to log in before you can comment on or make changes to this bug.