Problems with deleting near multiple spaces.

VERIFIED DUPLICATE of bug 82813

Status

()

Core
Editor
VERIFIED DUPLICATE of bug 82813
16 years ago
16 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: Joe Francis)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using Build ID: 2001112104
Steps to reproduce problem:
1. Open Editor
2. Format/Paragraph/Preformat
3. Type (without quotes) "   Test   Test   Test   Test   Test"
4. (Effect 1) Try deleting backwards from the start of the first word
5. (Effect 2) Try deleting forwards from the start of the line
6. (Effect 3) Try deleting one of the other "T"s (either forwards or backwards)
7. (Effect 4) Try deleting one of the remaining runs of spaces

Expected results: In all cases, exactly one adjacent character should be deleted

Actual results:
Effect 1: Nothing happens
Effect 2: The "T" is deleted
Effect 3: All but one of the spaces are deleted
Effect 4: All of the spaces are deleted

Additional information: Workaround: Select the text to be deleted first.
*** Bug 111975 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

16 years ago
Dupe of 82813.  Thanks for good testcases!

*** This bug has been marked as a duplicate of 82813 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.