Custom element, created with document.registerElement has no prototype

RESOLVED DUPLICATE of bug 1081037

Status

()

RESOLVED DUPLICATE of bug 1081037
4 years ago
4 years ago

People

(Reporter: kecskes.adam, Unassigned)

Tracking

36 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150108004006

Steps to reproduce:

I've enabled dom.webcomponents.enabled, and then tried to run this code:

var foo = document.registerElement('x-foo', {
    prototype: Object.create(HTMLElement.prototype)
});

// undefined in Firefox
console.log(foo.prototype);


Actual results:

For some reason, foo.prototype is undefined.


Expected results:

The custom element should have a prototype, like HTMLElement.
It works in chrome, or with the webcomponent.js fallback.

Comment 1

4 years ago
This works on Nightly (38). I imagine it's been fixed elsewhere, just not sure where.
Component: Untriaged → DOM
OS: Windows 7 → All
Product: Firefox → Core
Hardware: x86_64 → All
Whiteboard: DUPEME

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081037
You need to log in before you can comment on or make changes to this bug.