Stop using mozilla-centos-i386 mock

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: glandium, Assigned: glandium)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Assignee

Description

5 years ago
+++ This bug was initially created as a clone of Bug #947462 +++

The last places to use it are:
in m-c:
  b2g/config/hamachi/config.json
  b2g/config/hamachi/limited-memory-config.json
  b2g/config/helix/config.json
  b2g/config/wasabi/config.json
in mozharness:
  configs/single_locale/linux.py
Assignee

Comment 1

5 years ago
Presumably, this should work.

For whoever comes first.
Assignee: nobody → mh+mozilla
Attachment #8546910 - Flags: review?(rail)
Attachment #8546910 - Flags: review?(mshal)
Attachment #8546910 - Flags: review?(catlee)
Attachment #8546910 - Flags: review?(bhearsum)
Assignee

Comment 2

5 years ago
Attachment #8546911 - Flags: review?(catlee)
Assignee

Comment 3

5 years ago
(In reply to Mike Hommey [:glandium] from comment #2)
> Created attachment 8546911 [details] [diff] [review]
> mozharness part

Note that the package list already has the i686 packages listed, interestingly.
Comment on attachment 8546910 [details] [diff] [review]
0001-Bug-1119997-Stop-using-mozilla-centos-i386-mock.patch

Review of attachment 8546910 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8546910 - Flags: review?(rail)
Attachment #8546910 - Flags: review?(mshal)
Attachment #8546910 - Flags: review?(catlee)
Attachment #8546910 - Flags: review?(bhearsum)
Attachment #8546910 - Flags: review+
Comment on attachment 8546911 [details] [diff] [review]
mozharness part

I'll defer to Massimo for this one, since he's working on the repacks.
Attachment #8546911 - Flags: review?(catlee) → review?(mgervasini)
Attachment #8546911 - Flags: review?(mgervasini) → review+
Assignee

Comment 9

5 years ago
Can this be tested before landing, or should I land and we'll see what happens?
Flags: needinfo?(mgervasini)
I have tested the mozharness changes on the staging environment, the mock setup step was successful.
Flags: needinfo?(mgervasini)
Assignee

Comment 11

5 years ago
(In reply to Massimo Gervasini [:mgerva] from comment #10)
> I have tested the mozharness changes on the staging environment, the mock
> setup step was successful.

The more interesting thing is whether what happens in that mock environment works.
Flags: needinfo?(mgervasini)
Yes, I can confirm that the mock environment works too.
Flags: needinfo?(mgervasini)
Assignee

Comment 13

5 years ago
(In reply to Massimo Gervasini [:mgerva] from comment #12)
> Yes, I can confirm that the mock environment works too.

Let me rephrase: do those l10n jobs that run with that particular mozharness setup still work with this change?
Assignee

Updated

5 years ago
Flags: needinfo?(mgervasini)
Yes they work! Thanks!
Flags: needinfo?(mgervasini)
Assignee

Comment 15

5 years ago
https://hg.mozilla.org/build/mozharness/rev/fdcf9076afec

Leaving open until this is merged on the production branch.
Keywords: leave-open
Assignee

Updated

5 years ago
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.