Closed Bug 1120048 Opened 5 years ago Closed 5 years ago

Strange formatting on inline URLs

Categories

(bugzilla.mozilla.org :: Extensions, defect)

Production
x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: peterbe, Assigned: glob)

References

()

Details

Attachments

(1 file)

Best described by looking at this comment:
https://bugzilla.mozilla.org/show_bug.cgi?id=1119347#c4
You can see the transformation by pasting the URL (as given in the URL field above) into the comment-entry box and then switching to the Preview tab. It always generates the mangled URL seen in comment 1.
This is not an upstream bug. Bugzilla automatically linkifies URLs, but bmo has a customization to also convert rXXXXX into a URL. So both code are trying to linkify the same string. The bmo customization shouldn't try to linkify rXXXXX when it's part of a URL.
Assignee: ui → nobody
Component: User Interface → Extensions: BMO
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production
Attached patch 1120048_1.patchSplinter Review
it's much easier to to check for whitespace preceding the "r".
there's also no need to html_quote a string which matches \d{4,}
Assignee: nobody → glob
Status: NEW → ASSIGNED
Attachment #8552234 - Flags: review?(dylan)
Duplicate of this bug: 1132383
Comment on attachment 8552234 [details] [diff] [review]
1120048_1.patch

Review of attachment 8552234 [details] [diff] [review]:
-----------------------------------------------------------------

r=dylan

I also note this solution is a bit less than ideal, as well.
Attachment #8552234 - Flags: review?(dylan) → review+
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   42e7bbf..c8c9ad0  master -> master
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Component: Extensions: BMO → Extensions
You need to log in before you can comment on or make changes to this bug.