implement offset-{block,inline}-{start,end} logical properties

RESOLVED FIXED in mozilla38

Status

()

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: heycam, Assigned: heycam)

Tracking

(Blocks 2 bugs, {dev-doc-complete})

Trunk
mozilla38
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Assignee

Description

5 years ago
No description provided.
Assignee

Updated

5 years ago
Depends on: 1120284
Assignee

Updated

5 years ago
Attachment #8547372 - Attachment description: 0030-Bug-1120283-Part-1-Implement-the-offset-block-inline.patch → Part 1: Implement the offset-{block,inline}-{start,end} logical properties.
Assignee

Comment 2

5 years ago
Attachment #8547373 - Flags: review?(dbaron)
Assignee

Updated

5 years ago
Duplicate of this bug: 1071099
Attachment #8547372 - Flags: review?(dbaron) → review+
Comment on attachment 8547373 [details] [diff] [review]
Part 2: Tests.

>+      if (/offset/.test(p)) {

Maybe /^offset/ ?
Attachment #8547373 - Flags: review?(dbaron) → review+
Assignee

Updated

5 years ago
Keywords: dev-doc-needed
https://hg.mozilla.org/mozilla-central/rev/a9232db22dcd
https://hg.mozilla.org/mozilla-central/rev/77dd16c161b1
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
See Also: → 1132859
offset-inline-{start,end} don't seem to work as expected.

Test case:
data:text/html,<!DOCTYPE html><style>div{position:absolute;background:yellow;width:100px;height:100px;}p{position:absolute;margin:0;background:olive;offset-inline-start:0;}</style><div><p style="writing-mode:vertical-lr;">Test</p><p style="writing-mode:vertical-rl;">Test</p></div>

I'd expect one paragraph being positioned at the bottom left of the yellow <div>.

Sebastian
Flags: needinfo?(cam)
My fault. It works as expected. Same reasoning as in https://bugzilla.mozilla.org/show_bug.cgi?id=1083134#c59.

Sebastian
Flags: needinfo?(cam)
You need to log in before you can comment on or make changes to this bug.