Continual Flash crashes in Firefox 31 with most recent Flash

VERIFIED DUPLICATE of bug 789379

Status

()

Core
Plug-ins
--
critical
VERIFIED DUPLICATE of bug 789379
3 years ago
3 years ago

People

(Reporter: laing.nick, Unassigned)

Tracking

({crash, flashplayer})

31 Branch
x86_64
Windows 7
crash, flashplayer
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140724192552

Steps to reproduce:

Flash continually crashes, with no seemingly content\page specific pattern to the crash.
First seen as a hang which after 60secs you will get the plugin crash notice. Always Flash
Have tried multipl re-installs, clean outs, reboots, versions, disable HW acceleration etc.

This happens throughout our corp fleet and makes up the most significant complaints from 3000+ users. Would like to get to the bottom of whats causing it.

I would like t


Actual results:

Signature 	hang | WaitForMultipleObjectsEx | RealMsgWaitForMultipleObjectsEx | MsgWaitForMultipleObjects | F_1152915508___________________________________ More Reports Search
UUID 	8867073e-5b9f-4aee-aa7b-e29292150112
Date Processed	2015-01-12 04:21:49.266932
Process Type 	plugin Shockwave Flash Version:16.0.0.235 Filename:NPSWF32_16_0_0_235.dll
Uptime	3129
Install Age 	8380158 since version was first installed.
Install Time 	2014-10-07 03:23:55
Product 	Firefox
Version 	31.0
Build ID 	20140724192552
Release Channel 	default
OS 	Windows NT
OS Version 	6.1.7601 Service Pack 1
Build Architecture 	x86
Build Architecture Info 	GenuineIntel family 6 model 69 stepping 1 | 4
Crash Reason 	EXCEPTION_BREAKPOINT
Crash Address 	0x776d015d
User Comments 	
App Notes 	

AdapterVendorID: 0x8086, AdapterDeviceID: 0x0a16, AdapterSubsysID: 221417aa, AdapterDriverVersion: 10.18.10.3496
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 

Processor Notes 	sp-processor05_phx1_mozilla_com.22017:2012; MozillaProcessorAlgorithm2015; non-integer value of "SecondsSinceLastCrash"


Expected results:

Reliable, non-leaky usage and ability to show flash content. If HW or resource issues, a related error message alluding to this would be useful.
(Reporter)

Updated

3 years ago
Severity: normal → critical
Keywords: addon-compat, common-issue+, crash, flashplayer, reproducible, shockwave
Priority: -- → P2
Can you provide some crash report IDs for these crashes? They're available from about:crashes .
Component: Untriaged → Plug-ins
Flags: needinfo?(laing.nick)
Keywords: addon-compat, common-issue+, reproducible, shockwave
Priority: P2 → --
Product: Firefox → Core
(Reporter)

Comment 2

3 years ago
Submitted Crash Reports
Report ID 	Date Submitted
bp-58aba394-520f-4167-a259-1a79f2150116	1/16/2015	4:04 PM
95ea1b68-3724-4ed0-b395-f2a4d2d6fb53	1/14/2015	7:00 PM
bp-694ea96c-3675-4dbd-9440-062c22150113	1/13/2015	4:13 PM
bp-8867073e-5b9f-4aee-aa7b-e29292150112	1/12/2015	12:21 PM
fb1fa620-d3cf-42c3-a5ac-35c72cf5a0c6	1/10/2015	4:24 AM
1c563b3f-92fd-48b6-8efd-1dfc2850224e	1/9/2015	4:49 PM
e1b791ed-23f9-4575-9ce2-4ae9c29e65d7	1/7/2015	11:05 AM
227e8dd8-1677-461a-8af3-829e31f1deb8	1/7/2015	8:42 AM
d801f8a7-b7cd-436b-aa96-a7f9fa8af96f	1/7/2015	8:39 AM
eee7f40d-e578-4650-9bc5-4f15df25d87f	1/7/2015	8:39 AM
5463bd7b-5704-4f1a-ad33-88514abf8f39	1/7/2015	8:20 AM
47363884-6279-4865-a608-89c10834a462	1/6/2015	12:50 PM
b84b8974-8f82-41d3-9c0b-6001945d9429	1/5/2015	5:35 PM
a681a50d-21b5-42ca-9ea4-b4fdd6d2b6d0	1/5/2015	3:48 PM
56033be3-7f07-4c55-a87e-3581d18fb5fc	1/5/2015	3:47 PM
66280f10-0e7e-4697-a759-cd01770053c5	1/5/2015	2:39 PM
ca6b59d7-27a3-43ff-8475-c23e154701ff	1/2/2015	2:03 PM
98cd87bc-a365-44cb-8714-9b40a4bb593b	12/30/2014	1:21 PM
570b445d-cce8-491d-944b-6b3a4ff23a3b	12/30/2014	1:06 PM
467e34c5-a9a7-4c9c-b9d7-23c3c9859254	12/23/2014	2:41 PM
42641d81-3430-40ac-8e47-d754bc88f770	12/17/2014	3:20 PM
a24b31b7-67e9-4125-aef6-1ddf9a8d64d6	12/10/2014	4:06 PM
Flags: needinfo?(laing.nick)
I've heard that other people have success with turning off Flash's "Protected mode". On the other hand, that may have downsides of its own (I'm not familiar enough with Flash to tell you either way - please do research before following this advice :-) ).

Other than that, yes, we would like this fixed also, but the lack of specific steps to reproduce and the fact that the crashes themselves are in Flash mean that it's difficult for us to get that to happen.
Blocks: 774281, 789379

Comment 4

3 years ago
I believe I'm getting the same bug, except that I'm on beta build and a different crash thread. Been having this problem for months though..

https://crash-stats.mozilla.com/report/index/03698540-65b2-4e24-af1d-73d452150121
I guess you use the Firefox ESR Version?

Even when I think this shouldn't change anything to your Flash problems, I would suggest you to update your FF to the latest 31.xESR Version and Flash again to also the latest version.

I see in you list of "Submitted Crash Reports" that there are a lot of crashes not send out.
Thats normally crashes that are not actionable without more informations to reproduce.
But you can send them out anyway to see the exact signature.
All crashes not starting with a "bp-" are not send out yet.

If you can't provide steps to reproduce, this is a dup of Bug 774281, or Bug 789379.

If you can provide steps to reproduce your crashes, feel free to open this bug again.

Btw.: The next ESR Version is 38.0 and have a planed release on 2015-05-12. So maybe this version will fix your problems when you can't provide steps to reproduce this crash with FF31.xESR.
Status: UNCONFIRMED → RESOLVED
Crash Signature: [@ hang | WaitForMultipleObjectsEx | RealMsgWaitForMultipleObjectsEx | MsgWaitForMultipleObjects | F_1152915508___________________________________] [@ F1398665248_____________________________ ]
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 789379
No longer blocks: 774281, 789379
Status: RESOLVED → VERIFIED
Crash Signature: [@ hang | WaitForMultipleObjectsEx | RealMsgWaitForMultipleObjectsEx | MsgWaitForMultipleObjects | F_1152915508___________________________________] [@ F1398665248_____________________________ ]
You need to log in before you can comment on or make changes to this bug.