HTTP proxy setting for APN is not applied

RESOLVED FIXED in Firefox 38, Firefox OS v2.2

Status

Firefox OS
RIL
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: swu, Assigned: hchang)

Tracking

({regression})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8547377 [details]
Failure log

Device: Flame
Gecko: b8876c827edb
Gaia: d102cc0a7a1f346531553bec64588eea9e4594eb

When making data connection to APN which contains HTTP proxy, the proxy setting is not applied.  Attached is the log with NetworkManager & NetworkService and debug enabled.
(Reporter)

Comment 1

3 years ago
When the issue happened, the callback function of setDNS() was not called:
https://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/NetworkManager.js#1274
(Assignee)

Updated

3 years ago
Assignee: nobody → hchang
(Assignee)

Comment 2

3 years ago
Created attachment 8547484 [details] [diff] [review]
Bug1120302.patch
(Assignee)

Updated

3 years ago
Attachment #8547484 - Flags: review?(vchang)
(Assignee)

Comment 3

3 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a390665c8d26
Comment on attachment 8547484 [details] [diff] [review]
Bug1120302.patch

Review of attachment 8547484 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks.
Attachment #8547484 - Flags: review?(vchang) → review+
(Assignee)

Comment 5

3 years ago
(In reply to Vincent Chang[:vchang] from comment #4)
> Comment on attachment 8547484 [details] [diff] [review]
> Bug1120302.patch
> 
> Review of attachment 8547484 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks good, thanks.

Thanks for the review! Vincent
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Component: General → RIL
https://hg.mozilla.org/integration/b2g-inbound/rev/409240119a2b
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/409240119a2b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S4 (23jan)
(Assignee)

Comment 8

3 years ago
Comment on attachment 8547484 [details] [diff] [review]
Bug1120302.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): HTTP Proxy
User impact if declined: HTTP proxy will not applied when getting connected to network
Testing completed: yes
Risk to taking this patch (and alternatives if risky): No
String or UUID changes made by this patch: No
Attachment #8547484 - Flags: approval-mozilla-b2g37?
triage: this is a regression. It's impact on the case when HTTP proxy is used.
blocking-b2g: --- → 2.2+
Keywords: regression

Updated

3 years ago
Attachment #8547484 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2f73089f043a
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
status-firefox36: --- → wontfix
status-firefox37: --- → wontfix
status-firefox38: --- → fixed
You need to log in before you can comment on or make changes to this bug.